Bug 1023201 - rhsc-shell command yields python exception
rhsc-shell command yields python exception
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
high Severity urgent
: ---
: RHGS 2.1.2
Assigned To: Aravinda VK
Dustin Tsang
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-24 17:11 EDT by Dustin Tsang
Modified: 2015-07-13 00:39 EDT (History)
7 users (show)

See Also:
Fixed In Version: 2.1.2.0-0.2 CB6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-06 08:30:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dustin Tsang 2013-10-24 17:11:21 EDT
Description of problem:
rhsc-shell command yields a python exception

<command>
[root@rhsc-cb5 ~]# rhsc-shell
Traceback (most recent call last):
  File "/usr/bin/rhsc-shell", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 2655, in <module>
    working_set.require(__requires__)
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 648, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 546, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: rhsc-sdk>=2.1.0.0-0.bb3a
</command>



Version-Release number of selected component (if applicable):
rhsc-cb5 

How reproducible:
100% 


Steps to Reproduce:
1. ssh to rhsc host
2. run command 'rhsc-shell'


Actual results:
following trace is shown:
<stacktrace>
Traceback (most recent call last):
  File "/usr/bin/rhsc-shell", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 2655, in <module>
    working_set.require(__requires__)
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 648, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 546, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: rhsc-sdk>=2.1.0.0-0.bb3a
</stacktrace>


Expected results:
user enters rhsc-shell and receives welcome message


Additional info:
Comment 2 Dustin Tsang 2013-11-05 12:31:53 EST
also an issue in rhsc-cb6
Comment 3 Dustin Tsang 2013-11-05 12:31:53 EST
also an issue in rhsc-cb6
Comment 4 Dustin Tsang 2013-11-06 08:30:07 EST
closed as not a bug

Note You need to log in before you can comment on or make changes to this bug.