Bug 1023221 - Packstack should configure Swift middleware that's used in Tempest
Packstack should configure Swift middleware that's used in Tempest
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
4.0
Unspecified Unspecified
medium Severity medium
: z1
: 5.0 (RHEL 7)
Assigned To: Lukas Bezdicka
nlevinki
: TestOnly, Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-24 18:46 EDT by Martina Kollarova
Modified: 2016-04-26 12:16 EDT (History)
14 users (show)

See Also:
Fixed In Version: openstack-packstack-2014.1.1-0.25.dev1149.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-30 13:50:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/swift/proxy-server.conf (1.08 KB, text/plain)
2013-10-24 18:47 EDT, Martina Kollarova
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 57484 None None None Never
OpenStack gerrit 81198 None None None Never
OpenStack gerrit 82021 None None None Never
OpenStack gerrit 92578 None None None Never
OpenStack gerrit 97259 None None None Never
OpenStack gerrit 98203 None None None Never

  None (edit)
Description Martina Kollarova 2013-10-24 18:46:31 EDT
Description of problem:
Some Swift middleware, which is required by Tempest to run successfully, is not configured by default. Some tests were failing until I added these:

  account_quotas container_quotas tempurl staticweb

In /etc/swift/proxy-server.conf, this is the default after the packstack installation:

  [pipeline:main]
  pipeline = healthcheck cache authtoken keystone proxy-server

Since I've seen some effort to prepare the deployment for Tempest, I think they should be included.


Version-Release number of selected component (if applicable):
openstack-packstack-2013.2.1-0.6.dev763.el6ost.noarch
openstack-swift-container-1.10.0-0.2.rc1.el6ost.noarch
openstack-swift-account-1.10.0-0.2.rc1.el6ost.noarch
openstack-swift-object-1.10.0-0.2.rc1.el6ost.noarch
openstack-swift-proxy-1.10.0-0.2.rc1.el6ost.noarch
openstack-swift-1.10.0-0.2.rc1.el6ost.noarch
openstack-swift-plugin-swift3-1.0.0-0.20120711git.1.el6ost.noarch

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Martina Kollarova 2013-10-24 18:47:06 EDT
Created attachment 815955 [details]
/etc/swift/proxy-server.conf
Comment 3 Alvaro Lopez Ortega 2013-11-18 08:26:54 EST
Merged. Moving to MODIFIED.
Comment 5 Scott Lewis 2013-11-19 11:54:30 EST
Auto adding >= MODIFIED bugs to beta
Comment 6 Martin Magr 2013-11-20 11:34:16 EST
Reverted 56798.
Comment 7 Attila Fazekas 2014-01-31 05:45:06 EST
Tempest friendly minimal havana pipeline is:
catch_errors healthcheck cache authtoken keystone tempurl staticweb container_quotas account_quotas proxy-server

Tempest friendly minimal icehouse pipeline will be:
catch_errors healthcheck cache container_sync crossdomain slo bulk authtoken keystone tempurl formpost staticweb container_quotas account_quotas proxy-server

AFAIK the new swift with 'container_sync' support is not packaged yet, it can be excluded until it is ready.

NOTE:
For my looks strange the keystoneauth is called as 'keystone', would be simpler to read/write the config file if it would be 'keystoneaouth'.

NOTE: devstack uses the following pipeline:
catch_errors gatekeeper healthcheck proxy-logging cache container_sync bulk slo ratelimit crossdomain authtoken keystoneauth tempauth  tempurl formpost staticweb container-quotas account-quotas proxy-logging  ceilometer proxy-server
Comment 10 Ivan Chavero 2014-03-17 21:52:23 EDT
container_sync crossdomain and proxy-server are not yet available on the swift-puppet module. adding the options that are currently available.
Comment 11 Martin Magr 2014-03-25 15:37:33 EDT
Had to do quickfixes:

https://review.openstack.org/#/c/82021/
https://review.openstack.org/#/c/82029/
Comment 12 Martin Magr 2014-03-25 15:39:44 EDT
Those fixes made Swift installable, but unfortunately broke solution of this bug.
Comment 13 Lukas Bezdicka 2014-05-07 09:07:46 EDT
Swift will get enabled again by default, I created patch that enables all middlewares for icehouse except for container_sync and crossdomain. These two will probably require patching puppet-swift. I'll start working on it right away.
Comment 14 Attila Fazekas 2014-06-05 06:58:56 EDT
The "bulk catch_errors healthcheck cache ratelimit authtoken keystone staticweb tempurl slo formpost account-quotas container-quotas proxy-server" pipeline is wrong.

The catch_errors MUST be the FIRST in the pipeline !

See also: https://bugzilla.redhat.com/show_bug.cgi?id=1051113

BTW: the current default devstack pipeline is:
pipeline = catch_errors gatekeeper healthcheck proxy-logging cache container_sync bulk tempurl slo dlo ratelimit crossdomain authtoken keystoneauth tempauth  formpost staticweb container-quotas account-quotas proxy-logging  proxy-server

'dlo' is new.
Comment 16 Martin Magr 2014-07-28 05:09:45 EDT
Setting correct bug status since this is RHOS-4 bug.
Comment 17 Martin Magr 2014-07-28 07:44:22 EDT
According to discussion with Attila, I'm re-targeting this bug to RHO-5.
Comment 19 Dafna Ron 2014-09-12 11:45:19 EDT
the requested have been added to the /etc/swift/proxy-server.conf: 

pipeline = catch_errors bulk healthcheck cache crossdomain ratelimit authtoken keystone staticweb tempurl slo formpost account_quotas container_quotas proxy-server

moving to verified on: 
[root@tigris01 ~]# rpm -qa |grep swift 
openstack-swift-object-1.13.1-3.el7ost.noarch
python-swiftclient-2.1.0-2.el7ost.noarch
openstack-swift-1.13.1-3.el7ost.noarch
openstack-swift-plugin-swift3-1.7-3.el7ost.noarch
openstack-swift-account-1.13.1-3.el7ost.noarch
openstack-swift-proxy-1.13.1-3.el7ost.noarch
openstack-swift-container-1.13.1-3.el7ost.noarch
[root@tigris01 ~]# rpm -qa |grep packstack
openstack-packstack-2014.1.1-0.40.dev1239.el7ost.noarch
openstack-packstack-puppet-2014.1.1-0.40.dev1239.el7ost.noarch
[root@tigris01 ~]#
Comment 23 errata-xmlrpc 2014-09-30 13:50:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1324.html

Note You need to log in before you can comment on or make changes to this bug.