Bug 1023241 - digikam Memory leak while updating thumbnails (libPGF - bug)
digikam Memory leak while updating thumbnails (libPGF - bug)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: digikam (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Steven M. Parrish
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-24 21:29 EDT by Jim Shipman
Modified: 2013-12-05 05:34 EST (History)
6 users (show)

See Also:
Fixed In Version: libpgf-6.13.45-0.1.svn123.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-23 22:50:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 326525 None None None Never

  None (edit)
Description Jim Shipman 2013-10-24 21:29:06 EDT
Tools->Maintainance->Rebuild Thumbnails (scan changed) generates large memory leak.
Fedora 19 Gnome, X86_64 w/ 12GB Memory, AMD quad core, MySQL database on local machine.
Yum installed from Fedora 19 repository - digikam 3.5.0
Memory goes from a few GB linearly up to 11GB during the scan for changed/new thumbnails.

2013-10-23
Submitted to the KDE bug tracking system as digikam bug 326525, but the problem seems to be in the libPGF library which is built as external shared in the Fedora distro.  This does not happen with the libPGF provided in the digikam core source.

Reproducible: Always

Steps to Reproduce:
1.Select Maintainance->Rebuild thumbnails->scan for new
2. Watch the memory usage climb until you run out.
3.
Actual Results:  
Memory climbs linearly up to max available on the machine (12 GB)

Expected Results:  
Memory should be stable

I can't build thumbnails until this is fixed.
Comment 1 nucleo 2013-10-25 07:46:43 EDT
Last released libpgf 6.12.24. Trying 6.12.27 from svn.
Comment 2 Fedora Update System 2013-10-25 07:59:57 EDT
libpgf-6.12.27-0.1.svn119.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/libpgf-6.12.27-0.1.svn119.fc19
Comment 3 Fedora Update System 2013-10-25 08:01:47 EDT
libpgf-6.12.27-0.1.svn119.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/libpgf-6.12.27-0.1.svn119.fc18
Comment 4 Fedora Update System 2013-10-25 08:03:43 EDT
libpgf-6.12.27-0.1.svn119.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libpgf-6.12.27-0.1.svn119.fc20
Comment 5 nucleo 2013-10-25 12:56:49 EDT
Can you please test libpgf-6.12.27-0.1.svn119.fc19
http://koji.fedoraproject.org/koji/buildinfo?buildID=473717

If it don't fixes bug I will try to build libpgf with -DLIBPGF_DISABLE_OPENMP.
Comment 6 Fedora Update System 2013-10-25 13:44:25 EDT
Package libpgf-6.12.27-0.1.svn119.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libpgf-6.12.27-0.1.svn119.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19928/libpgf-6.12.27-0.1.svn119.fc20
then log in and leave karma (feedback).
Comment 7 nucleo 2013-10-27 07:02:56 EDT
Please test libpgf-6.12.27-0.2.svn119.fc19 built with -DLIBPGF_DISABLE_OPENMP
https://admin.fedoraproject.org/updates/FEDORA-2013-19959
Comment 8 Fedora Update System 2013-11-23 22:50:32 EST
libpgf-6.13.45-0.1.svn123.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2013-12-05 05:30:26 EST
libpgf-6.13.45-0.1.svn123.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-12-05 05:34:50 EST
libpgf-6.13.45-0.1.svn123.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.