Bug 102328 - LTC3920-[BETA] DB2 v8.1 FP2 doesn't install on Beta 1 RHEL 3
LTC3920-[BETA] DB2 v8.1 FP2 doesn't install on Beta 1 RHEL 3
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: glibc (Show other bugs)
3.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-13 17:26 EDT by IBM Bug Proxy
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-14 08:32:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2003-08-13 17:26:07 EDT
The following has be reported by IBM LTC:  
[BETA] DB2 v8.1 FP2 doesn't install on Beta 1 RHEL 3
Please fill in each of the sections below.

Hardware Environment: IA64 system.  4 cpu 

Software Environment: Red Hat Enterprise Linux 3 Beta 1


Steps to Reproduce:
1. Install RHEL 3, Beta 1, install all errata listed from RHN 
2. Take DB2 install image and attempt to install on RHEL 3, Beta 1

Actual Results: Message generated by the install program:
[root@panda99 download]# ./ese/db2setup
/download/ese/db2/linux64/install/../bin/disp_msg: relocation 
error: /download/ese/db2/linux64/install/../bin/disp_msg: symbol _dl_loaded, 
version GLIBC_2.2 not defined in file ld-linux-ia64.so.2 with link time 
reference


Expected Results: JAVA gui starts up to begin install.

Additional Information:
This symbol existed on RH AS 2.1:
[root@it2 lib]# nm -o ld-2.2.4.so | grep dl_loaded
ld-2.2.4.so:0000000000042680 S _dl_loaded

But not on RH EL 3:
[root@panda99 lib]# nm -o ld-linux-ia64.so.2 | grep dl_loaded
[root@panda99 lib]# 

Please advise.  Should this symbol be here?  We have not explicitly added it in 
our build env. as far as we can tell.

If you need a copy of DB2, please let me know.. Otherwise the DB2 for Linux 
IA64 can be downloaded from the www.ibm.com/db2 website.

thanks,
yvonne.
Glen/Greg - probably the quickest way is to ask Red Hat about this dl_loaded
symbol which does not seem to exist in RHEL3 beta1.  Thanks.
Comment 1 Jakub Jelinek 2003-08-14 08:32:19 EDT
_dl_loaded used to be ld.so's private symbol, no application should ever use it
(and is no longer present in glibc 2.3+ and even if it would, it would be
marked as GLIBC_PRIVATE).
If applications need to look at what libraries are loaded, glibc provides
dl_iterate_phdr interface.
Comment 2 IBM Bug Proxy 2003-08-14 10:26:14 EDT
------ Additional Comments From yvchan@ca.ibm.com  2003-14-08 10:10 -------
I can't seem to add anything to the Red Hat bugzilla bug system.  (I have an 
id, just don't have permission). 

I was able to track down where the symbol came from.  It looks like DB2 didn't 
add it in, but rather the Intel compiler did.  I will pursue this with them.

yvonne. 
Comment 3 IBM Bug Proxy 2003-08-18 14:08:48 EDT
------ Additional Comments From greg_kelleher@us.ibm.com  2003-18-08 13:21 -------
Chatted with Yvonne. They were able to track down where the symbol came from.  
It looks like DB2 didn't add it in, but rather the Intel compiler did.  

This is be followed-upon with Intel

Greg 

Note You need to log in before you can comment on or make changes to this bug.