Bug 1023321 - [abrt] system-config-printer-1.4.1-6.fc19: printerproperties.py:1573:updateMarkerLevels:UnicodeEncodeError: 'ascii' codec can't encode character u'\xe9' in position 10: ordinal not in range(128)
[abrt] system-config-printer-1.4.1-6.fc19: printerproperties.py:1573:updateMa...
Status: CLOSED DUPLICATE of bug 1046466
Product: Fedora
Classification: Fedora
Component: python-cups (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:68960cabb727ec87a9390f76238...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-25 04:04 EDT by Fujisan
Modified: 2014-02-17 11:04 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-17 11:04:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.24 KB, text/plain)
2013-10-25 04:04 EDT, Fujisan
no flags Details
File: core_backtrace (492 bytes, text/plain)
2013-10-25 04:04 EDT, Fujisan
no flags Details
File: environ (1.36 KB, text/plain)
2013-10-25 04:04 EDT, Fujisan
no flags Details
The error in ABRT (46.84 KB, image/png)
2013-10-28 08:41 EDT, Fujisan
no flags Details

  None (edit)
Description Fujisan 2013-10-25 04:04:40 EDT
Description of problem:
Added a network printer with the "Print Settings" tool and printed a test page.

Version-Release number of selected component:
system-config-printer-1.4.1-6.fc19

Additional info:
reporter:       libreport-2.1.5
cmdline:        /usr/bin/python /usr/share/system-config-printer/system-config-printer.py
dso_list:       system-config-printer-libs-1.4.1-6.fc19.noarch
executable:     /usr/share/system-config-printer/system-config-printer.py
kernel:         3.9.5-301.fc19.x86_64
runlevel:       N 5
uid:            0

Truncated backtrace:
printerproperties.py:1573:updateMarkerLevels:UnicodeEncodeError: 'ascii' codec can't encode character u'\xe9' in position 10: ordinal not in range(128)

Traceback (most recent call last):
  File "/usr/share/system-config-printer/printerproperties.py", line 1903, in on_printer_event
    self.on_printer_modified (None, printer, False)
  File "/usr/share/system-config-printer/printerproperties.py", line 1893, in on_printer_modified
    self.updatePrinterProperties ()
  File "/usr/share/system-config-printer/printerproperties.py", line 1679, in updatePrinterProperties
    self.updateMarkerLevels ()
  File "/usr/share/system-config-printer/printerproperties.py", line 1573, in updateMarkerLevels
    localized_name = self.ppd.localizeMarkerName(name)
UnicodeEncodeError: 'ascii' codec can't encode character u'\xe9' in position 10: ordinal not in range(128)

Local variables in innermost frame:
num_markers: 1
color: u'none'
cols: 4
can_refresh: True
table: <Table object at 0x3235fa0 (GtkTable at 0x3206120)>
row: 0
localized_name: None
rows: 2
val: [-1, -1, -1, -1, -1, -1]
self: <PrinterPropertiesDialog object at 0x1ca62d0 (printerproperties+PrinterPropertiesDialog at 0x18e8180)>
markers: [(u'#000000', u'Toner noir', u'toner', -1), (u'none', u'Toner usag\xe9 1', u'wasteToner', -1), (u'#00FFFF', u'Toner cyan', u'toner', -1), (u'#FF00FF', u'Toner magenta', u'toner', -1), (u'#FFFF00', u'Toner jaune', u'toner', -1), (u'none', u'Toner usag\xe9 2', u'wasteToner', -1)]
label: <Label object at 0x3240140 (GtkLabel at 0x2ec6300)>
widget: <Label object at 0x3235f50 (GtkLabel at 0x2f58a80)>
printer: <cupshelpers.Printer "ricoh">
marker_type: u'wasteToner'
typ: <type 'float'>
inklevel: <GtkInkLevel object at 0x3240410 (gtkinklevel+GtkInkLevel at 0x1ba2020)>
attr: 'marker-levels'
name: u'Toner usag\xe9 1'
level: -1
vbox: <VBox object at 0x3240460 (GtkVBox at 0x2e5a5c0)>
marker_info: {'marker-names': [u'Toner noir', u'Toner usag\xe9 1', u'Toner cyan', u'Toner magenta', u'Toner jaune', u'Toner usag\xe9 2'], 'marker-types': [u'toner', u'wasteToner', u'toner', u'toner', u'toner', u'wasteToner'], 'marker-levels': [-1, -1, -1, -1, -1, -1], 'marker-colors': [u'#000000', u'none', u'#00FFFF', u'#FF00FF', u'#FFFF00', u'none']}
col: 0
subhbox: <HBox object at 0x3240320 (GtkHBox at 0x320c880)>
Comment 1 Fujisan 2013-10-25 04:04:45 EDT
Created attachment 816037 [details]
File: backtrace
Comment 2 Fujisan 2013-10-25 04:04:49 EDT
Created attachment 816038 [details]
File: core_backtrace
Comment 3 Fujisan 2013-10-25 04:04:52 EDT
Created attachment 816039 [details]
File: environ
Comment 4 Jiri Popelka 2013-10-25 04:30:04 EDT
I have at the moment no idea what happened in this case, but we've fixed a lot of encoding related problems since version you are using.

Please update to 1.4.3 - it's in updates-testing now, so run

yum --enablerepo=updates-testing update 'system-config-printer*'

and let me know if you are able to reproduce the problem with 1.4.3.
Thanks
Comment 5 Fujisan 2013-10-28 08:38:32 EDT
Stil have the problem with system-config-printer 1.4.3.

https://retrace.fedoraproject.org/faf/reports/255324/
Comment 6 Fujisan 2013-10-28 08:41:13 EDT
Created attachment 816779 [details]
The error in ABRT
Comment 7 Jiri Popelka 2013-10-29 09:43:50 EDT
(In reply to Fujisan from comment #0)
>     localized_name = self.ppd.localizeMarkerName(name)
> UnicodeEncodeError: 'ascii' codec can't encode character u'\xe9' in position
> 10: ordinal not in range(128)
> ...
> name: u'Toner usag\xe9 1'

Thanks,
seems to be a problem in python-cups - PPD_localizeMarkerName() doesn't accept unicode. I'll take a look.
Comment 8 Jiri Popelka 2013-10-31 10:01:28 EDT
Should be fixed upstream with
https://git.fedorahosted.org/cgit/pycups.git/commit/?id=a228a7ac757c12798bd2e253a787651d0afdd3e4
Comment 9 Tim Waugh 2014-02-17 11:04:23 EST

*** This bug has been marked as a duplicate of bug 1046466 ***

Note You need to log in before you can comment on or make changes to this bug.