Bug 1023326 - Remove icons option from pack selection panels.
Remove icons option from pack selection panels.
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Installer (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity low
: CR2
: EAP 6.2.0
Assigned To: Miles Tjandrawidjaja
Petr Kremensky
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-25 04:18 EDT by Petr Kremensky
Modified: 2014-09-03 00:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:15:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Kremensky 2013-10-25 04:18:13 EDT
Description of problem:
 There is 'Icons' option on pack selection panel, this option is disabled so user cannot edit it and is selected as required, however icons selection itself is made at the end of installation so this option here can be removed as it has no meaning here.

Version-Release number of selected component (if applicable):
 EAP 6.2.0.ER6

How reproducible:
 Always

Steps to Reproduce:
 1. Run console installation
 2. Continue using default values until you reach "Select the packs you want to install:" panel 

Actual results:
 13   [x] [Required]      [Icons]

Expected results:
 No option to install Icons is shown here (neither in GUI installation).

Additional info:
 How about Icons on Mac OS? Panel to install icons is missing here and EAP cannot be found among applications once the installation is done. Is this intention? (I am total newbie with this platform :/)
Comment 1 Miles Tjandrawidjaja 2013-10-29 16:29:30 EDT
Hello,

We've been discussing about removing the icons from the installation entirely.
I believe its been requested a few time before.
This is because shortcuts causes quite a few problems, are platform independent and seem to be of low value. Please let us know if this request can be approved, I believe this option has already been removed from the FSW installation.
Comment 2 Petr Kremensky 2013-10-30 04:10:50 EDT
Hi,
this is a more question for PM. 

@John please read comment 1. 
Thanks
Comment 3 Miles Tjandrawidjaja 2013-11-18 12:08:57 EST
For the time being option to install icons are not shown in GUI or Console installation anymore.

http://git.app.eng.bos.redhat.com/jbossas-installer.git/commit/?h=eap-6.2&id=cb37f2ecd03b6eb6dfd855ced55ff5af43f8a0db
Comment 4 Petr Kremensky 2013-11-19 04:27:34 EST
Verified on EAP 6.2.0.CR2 installer. There is no icons item in pack selection panel anymore.

Note You need to log in before you can comment on or make changes to this bug.