Bug 102341 - at: Should support -r besides -d
Summary: at: Should support -r besides -d
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: at (Show other bugs)
(Show other bugs)
Version: 9
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact: Mike McLean
URL: http://www.unix.org/single_unix_speci...
Whiteboard:
Keywords:
Depends On:
Blocks: 145411 163896
TreeView+ depends on / blocked
 
Reported: 2003-08-14 00:19 UTC by Tobias Burnus
Modified: 2007-04-18 16:56 UTC (History)
0 users

Fixed In Version: at-3.1.8-78
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-03 18:33:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch at-3.1.8 (908 bytes, patch)
2003-08-15 12:29 UTC, Tobias Burnus
no flags Details | Diff

Description Tobias Burnus 2003-08-14 00:19:10 UTC
Description of problem:

The SUSv3 (IEEE Std 1003.1-2003) requires that

"-r Remove the jobs with the specified at_job_id operands that were previously
scheduled by the at utility."
is supported.

Since the LSB claims that -d and -r are equivalent, adding -r support should be
easy: Treat it like -d and add it to the help and manpage.



How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:

Comment 1 Tobias Burnus 2003-08-15 12:29:24 UTC
Created attachment 93654 [details]
Patch  at-3.1.8

This patch add -r, updates the manpage and adds the line from SuSv3 to the man
page:
   at -r at_job_id ...

Comment 2 Tobias Burnus 2003-10-01 20:42:45 UTC
Even better than my patch is this version:
   http://www.freebsd.org/cgi/cvsweb.cgi/src/usr.bin/at/
it also supports "-t timespec" and "at -l -q queue" which is also required by
POSIX/SUSv3.

Comment 3 Jason Vas Dias 2005-06-03 18:33:46 UTC
Sorry for the delay in getting around to this bug - it slipped
through the cracks somehow.

at already supports the ( -l -q queue ) and ( -t <timespec> )
arguments. 

Now modified to make '-r' a synonym for '-d' as required by the 
specification in Rawhide ( at-3.1.8-78 ) .



Note You need to log in before you can comment on or make changes to this bug.