Bug 1023426 - Reclaim space: not enough information to reclaim what is intended to be reclaimed
Reclaim space: not enough information to reclaim what is intended to be recla...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 1023459 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-25 07:40 EDT by Marian Csontos
Modified: 2015-04-13 13:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-13 13:03:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marian Csontos 2013-10-25 07:40:23 EDT
Description of problem:
Reclaim space displays only VG names which is not enough to make qualified guess which PV should be removed.

What's worse it does not display VG name when PV is directly on disk (without partition) so one can not distinguish free PV from allocated PV.

Neither is VG name displayed when not all disks in a VG were selected in "Installation destination" (Bug 1022811).

It also allows reclaiming single PV from a VG without warning user (similar to Bug 1022811.)

Version-Release number of selected component (if applicable):
20.25.1-1

How reproducible:
100%

Failures:

1. PV (whether used or unused by VG) directly on disk without partition - lvmpv only, no VG name to indicate it is in use
- When VG is used the name MUST be displayed.

2. VG - vg name + lvmpv is displayed. No information about LVs.
- When VG contains LVs there MUST be a way to display those.

3. Partial VG on a partition selected - lvmpv only is displayed (may look like unused PV)
- This should be prevented by resolving Bug 1022811.

4. Allows user to remove single PV from VG with multiple PVs wihthout warning.
- User MUST be warned given a chance to review affected LVs and decide what to do (keep PV, delete whole VG or force-delete single PV with emphasized disclaimer.)

5. Impossible to remove existing LVs (and pools).
- User SHOULD be able to remove existing LVs.
Comment 1 David Shea 2015-04-13 13:03:05 EDT
1) both the VG name and the name of the partition containing the lvmpv are displayed

2) Removing a partition from a volume group will effectively destroy the VG, and LVs to PVs is a potentially many to many relationship. Displaying LV information in the reclaim dialog is neither feasible nor useful.

3+4) bug 1209223

5) This is not the level the reclaim space dialog works at, use custom partitioning.
Comment 2 David Shea 2015-04-13 13:08:34 EDT
*** Bug 1023459 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.