Bug 1023452 - Save the value of "Logrotate Max Log Size" into file "/etc/logrotate.d/ovirt-node" failed
Save the value of "Logrotate Max Log Size" into file "/etc/logrotate.d/ovirt-...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
: TestOnly, ZStream
: 1023456 (view as bug list)
Depends On: 979296 1023456
Blocks: 1023957
  Show dependency treegraph
 
Reported: 2013-10-25 09:05 EDT by Fabian Deutsch
Modified: 2014-01-21 14:35 EST (History)
16 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-8.el6
Doc Type: Bug Fix
Doc Text:
Previously the value of "Logrotate Max Log Size" could not be saved in "/etc/logrotate.d/ovirt-node". This was because the ovirt-node configuration file for logrotate had an invalid syntax, which prevented augeas from being able to edit it. Now the syntax of the file has been fixed, and the value can be saved.
Story Points: ---
Clone Of: 979296
Environment:
Last Closed: 2014-01-21 14:35:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 16223 None None None Never

  None (edit)
Description Fabian Deutsch 2013-10-25 09:05:03 EDT
+++ This bug was initially created as a clone of Bug #979296 +++

Description of problem:
Enter into Logging page, then set the value of "Logrotate Max Log Size" as "2048",
check that the file "/etc/logrotate.d/ovirt-node"
[root@dhcp-10-202 admin]# cat /etc/logrotate.d/ovirt-node 
/var/log/ovirt*.log{
    rotate 3
    compress
    missingok
    size 1M
    create
}

the size was still "1M", not we set value "2048"

Maybe the root cause happen here:
>>> import ovirtnode.ovirtfunctions as _functions
>>> _functions.augtool("set", "/files/etc/logrotate.d/ovirt-node/rule/size", "2048")
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/ovirtnode/ovirtfunctions.py", line 109, in augtool
  File "/usr/lib/python2.7/site-packages/augeas.py", line 346, in save
IOError: Unable to save to file!
>>> 



Version-Release number of selected component (if applicable):
ovirt-node-iso-3.0.0-0.999.999.20130625144130gitd26f7bf.2621.fc18

How reproducible:
100%


Steps to Reproduce:



Actual results:


Expected results:


Additional info:

--- Additional comment from Fabian Deutsch on 2013-06-28 12:52:01 CEST ---

Augeas couldn't save the file because the syntax of the configuration file was broken.

The syntax is now updated.
Tested with augtool to see if augeas recognizes the file:
augtool ls /files/etc/logrotate.d/ovirt-node
Comment 2 Fabian Deutsch 2013-10-25 11:09:04 EDT
*** Bug 1023456 has been marked as a duplicate of this bug. ***
Comment 6 Cheryn Tan 2014-01-08 00:36:57 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:
https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes

Thank you for your help.
Comment 9 errata-xmlrpc 2014-01-21 14:35:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.