Bug 1023456 - Save the value of "Logrotate Max Log Size" into file "/etc/logrotate.d/ovirt-node" failed
Save the value of "Logrotate Max Log Size" into file "/etc/logrotate.d/ovirt-...
Status: CLOSED DUPLICATE of bug 1023452
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
:
Depends On: 979296
Blocks: 1023452
  Show dependency treegraph
 
Reported: 2013-10-25 09:09 EDT by Fabian Deutsch
Modified: 2013-10-25 11:09 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 979296
Environment:
Last Closed: 2013-10-25 11:09:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 16223 None None None Never

  None (edit)
Description Fabian Deutsch 2013-10-25 09:09:08 EDT
+++ This bug was initially created as a clone of Bug #979296 +++

Description of problem:
Enter into Logging page, then set the value of "Logrotate Max Log Size" as "2048",
check that the file "/etc/logrotate.d/ovirt-node"
[root@dhcp-10-202 admin]# cat /etc/logrotate.d/ovirt-node 
/var/log/ovirt*.log{
    rotate 3
    compress
    missingok
    size 1M
    create
}

the size was still "1M", not we set value "2048"

Maybe the root cause happen here:
>>> import ovirtnode.ovirtfunctions as _functions
>>> _functions.augtool("set", "/files/etc/logrotate.d/ovirt-node/rule/size", "2048")
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/ovirtnode/ovirtfunctions.py", line 109, in augtool
  File "/usr/lib/python2.7/site-packages/augeas.py", line 346, in save
IOError: Unable to save to file!
>>> 



Version-Release number of selected component (if applicable):
ovirt-node-iso-3.0.0-0.999.999.20130625144130gitd26f7bf.2621.fc18

How reproducible:
100%


Steps to Reproduce:



Actual results:


Expected results:


Additional info:

--- Additional comment from Fabian Deutsch on 2013-06-28 12:52:01 CEST ---

Augeas couldn't save the file because the syntax of the configuration file was broken.

The syntax is now updated.
Tested with augtool to see if augeas recognizes the file:
augtool ls /files/etc/logrotate.d/ovirt-node
Comment 2 Fabian Deutsch 2013-10-25 11:09:04 EDT

*** This bug has been marked as a duplicate of bug 1023452 ***

Note You need to log in before you can comment on or make changes to this bug.