Bug 1023507 - [engine-iso-uploader] INFO: Use the -h option to see usage - when put incorrect iso domain
[engine-iso-uploader] INFO: Use the -h option to see usage - when put incorre...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-iso-uploader (Show other bugs)
3.3.0
Unspecified Unspecified
medium Severity low
: ---
: 3.4.0
Assigned To: Simone Tiraboschi
Jiri Belka
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-25 11:01 EDT by Jiri Belka
Modified: 2014-06-09 10:15 EDT (History)
11 users (show)

See Also:
Fixed In Version: rhevm-iso-uploader-3.4.0-3.el6ev
Doc Type: Bug Fix
Doc Text:
* Previously, if a specific exception was raised for the engine-iso-uploader, a message to check the help for usage would follow the error message. This message has now been removed as it is redundant to specific exceptions when the error message itself contains the solution.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-09 10:15:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 27413 master MERGED Removing useless info line on specific exception Never
oVirt gerrit 27422 ovirt-iso-uploader-3.4 MERGED Removing useless info line on specific exception Never

  None (edit)
Description Jiri Belka 2013-10-25 11:01:24 EDT
Description of problem:
# engine-iso-uploader -i bjabljalfjalfjla upload ./usr/share/rhev-guest-tools-iso/RHEV-toolsSetup_3.2_16.iso 
Please provide the REST API password for the admin@internal oVirt Engine user (CTRL+D to abort): 
ERROR: An ISO storage domain with a name of bjabljalfjalfjla was not found.
INFO: Use the -h option to see usage.

the problem here is incorrect storage domain name, not syntax. so why to tell the user to see help? he won't find the name of valid domain there :)


Version-Release number of selected component (if applicable):
rhevm-iso-uploader-3.3.0-1.el6ev.noarch (is20)

How reproducible:
100%

Steps to Reproduce:
1. put invalid storage domain
2.
3.

Actual results:
useless info line

Expected results:
a user should see only error message

Additional info:
Comment 3 Jiri Belka 2014-05-13 07:39:16 EDT
ok, rhevm-iso-uploader-3.4.0-3.el6ev.noarch

[root@jb-rhevm34 ~]# engine-iso-uploader -i bjabljalfjalfjla upload ./usr/share/rhev-guest-tools-iso/RHEV-toolsSetup_3.4_4.el6ev.iso 
ERROR: An ISO storage domain with a name of bjabljalfjalfjla was not found.
[root@jb-rhevm34 ~]# rpm -qa rhevm-iso-uploader\*
rhevm-iso-uploader-3.4.0-3.el6ev.noarch
Comment 5 errata-xmlrpc 2014-06-09 10:15:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0666.html

Note You need to log in before you can comment on or make changes to this bug.