Bug 1023541 - When fifth snapshot is deleted, not data will be discarded
When fifth snapshot is deleted, not data will be discarded
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation (Show other bugs)
3.2.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Andrew Dahms
ecs-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-25 12:58 EDT by Sadique Puthen
Modified: 2014-05-26 21:29 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build Name: 9026, Technical Reference Guide-3.3 Build Date: 15-10-2013 13:53:41 Topic ID: 13706-383596 [Latest]
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sadique Puthen 2013-10-25 12:58:19 EDT
Title: Snapshot Deletion

Says:

"If the fifth snapshot out of five is deleted, then the data that has been modified or created since the snapshot was taken will be discarded."

The above is wrong. When a snapshot is deleted, be it first or fifth or last, data that has been modified or created since that snapshot was taken will not be discarded.

Describe the issue:


Suggestions for improvement:


Additional information:
Comment 1 Tim Hildred 2013-10-27 20:04:01 EDT
Reassigning to Jodi Biddle (jbiddle@redhat.com) as I am no longer working on Red Hat Enterprise Virtualization documentation.
Comment 2 Andrew Dahms 2013-12-12 00:44:23 EST
Thank you for raising this bug, Sadique. I understand that data that has been modified or created since a snapshot was taken will not be discarded when that snapshot is deleted.

However, if the fifth snapshot out of five snapshots is deleted, does this mean that the data that has been modified or created since the snapshot PRIOR TO the snapshot being deleted - in this case, since the fourth snapshot - will be discarded?

Any clarification you can provide on the intended behaviour would be appreciated.
Comment 3 Sadique Puthen 2013-12-12 01:50:20 EST
No data will be discarded when fifth snapshot is deleted.
Comment 4 Andrew Dahms 2014-01-07 19:28:19 EST
Documentation Link
------------------------------
http://documentation-devel.engineering.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.3/html-single/Technical_Reference_Guide/index.html#Snapshot_Deletion

What Changed
------------------------------
The following topic was revised to remove a sentence that incorrectly described the effects of deleting a snapshot:

Snapshot Deletion         [ 13706-570881 ]

Updated revision history: [ 21138-570884 ]

NVR
------------------------------
Red_Hat_Enterprise_Virtualization-Technical_Reference_Guide-3.3-en-US-3.3-10

Moving to ON_QA.

Note You need to log in before you can comment on or make changes to this bug.