Bug 1023608 - [abrt] cuneiform-1.1.0-15.fc20: average_inc: Process /usr/bin/cuneiform was killed by signal 8 (SIGFPE)
[abrt] cuneiform-1.1.0-15.fc20: average_inc: Process /usr/bin/cuneiform was k...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: cuneiform (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dmitrij S. Kryzhevich
Fedora Extras Quality Assurance
abrt_hash:84950f1bb5be52b02781fdd47fc...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-25 18:58 EDT by Lukáš Říha
Modified: 2014-12-22 12:33 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-01 22:52:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (18.50 KB, text/plain)
2013-10-25 18:58 EDT, Lukáš Říha
no flags Details
File: cgroup (159 bytes, text/plain)
2013-10-25 18:58 EDT, Lukáš Říha
no flags Details
File: core_backtrace (5.15 KB, text/plain)
2013-10-25 18:58 EDT, Lukáš Říha
no flags Details
File: dso_list (6.74 KB, text/plain)
2013-10-25 18:58 EDT, Lukáš Říha
no flags Details
File: environ (1.51 KB, text/plain)
2013-10-25 18:58 EDT, Lukáš Říha
no flags Details
File: limits (1.29 KB, text/plain)
2013-10-25 18:58 EDT, Lukáš Říha
no flags Details
File: maps (33.40 KB, text/plain)
2013-10-25 18:58 EDT, Lukáš Říha
no flags Details
File: open_fds (229 bytes, text/plain)
2013-10-25 18:58 EDT, Lukáš Říha
no flags Details
File: proc_pid_status (935 bytes, text/plain)
2013-10-25 18:58 EDT, Lukáš Říha
no flags Details
File: var_log_messages (389 bytes, text/plain)
2013-10-25 18:58 EDT, Lukáš Říha
no flags Details
File: SCAN0006.JPG (1.81 MB, application/octet-stream)
2013-10-25 18:58 EDT, Lukáš Říha
no flags Details

  None (edit)
Description Lukáš Říha 2013-10-25 18:58:03 EDT
Description of problem:
Learned Yagf (cuneiform as backend) to transfer opened images to text. Played with blocks of text. Couple pages worked OK. The error was repeatedly caused by repeated actual text recognition from one specific block from page of another (other then the previously tested) document. Other blocks on the same page cause no trouble - at least in the sense of causing cuneiform errors.

To reproduce:
1. Open YAGF
2. Load page image
3. Mark block of text (main block of text on left page (p.40))
4. Click "Recognize" (red OCR) button

This happened even after reboot.
Enclosed is the image that caused the problem.

Version-Release number of selected component:
cuneiform-1.1.0-15.fc20

Additional info:
reporter:       libreport-2.1.8
backtrace_rating: 4
cmdline:        cuneiform -l cze -f text -o /home/lukas/.config/yagf/output.txt /home/lukas/.config/yagf/input.bmp
crash_function: average_inc
executable:     /usr/bin/cuneiform
kernel:         3.11.6-300.fc20.x86_64
runlevel:       N 5
type:           CCpp

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 average_inc at /usr/src/debug/cuneiform-linux-1.1.0/cuneiform_src/Kern/rstr/src/erection.c:943
 #1 represent_inc at /usr/src/debug/cuneiform-linux-1.1.0/cuneiform_src/Kern/rstr/src/erection.c:975
 #2 get_incline_of_word at /usr/src/debug/cuneiform-linux-1.1.0/cuneiform_src/Kern/rstr/src/erection.c:1121
 #3 erection_incline_word at /usr/src/debug/cuneiform-linux-1.1.0/cuneiform_src/Kern/rstr/src/erection.c:1271
 #4 erection_incline_words at /usr/src/debug/cuneiform-linux-1.1.0/cuneiform_src/Kern/rstr/src/erection.c:678
 #5 pass3 at /usr/src/debug/cuneiform-linux-1.1.0/cuneiform_src/Kern/rstr/src/pass3.c:697
 #6 RSTRRecognizeMain at /usr/src/debug/cuneiform-linux-1.1.0/cuneiform_src/Kern/rstr/src/rcm.c:1688
 #7 RSTRRecognize at /usr/src/debug/cuneiform-linux-1.1.0/cuneiform_src/Kern/rstr/src/rcm.c:1370
 #8 RecognizeStringsPass1 at /usr/src/debug/cuneiform-linux-1.1.0/cuneiform_src/Kern/puma/c/partrecog.cpp:252
 #9 Recognize at /usr/src/debug/cuneiform-linux-1.1.0/cuneiform_src/Kern/puma/c/partrecog.cpp:625

Potential duplicate: bug 1010835
Comment 1 Lukáš Říha 2013-10-25 18:58:06 EDT
Created attachment 816299 [details]
File: backtrace
Comment 2 Lukáš Říha 2013-10-25 18:58:09 EDT
Created attachment 816300 [details]
File: cgroup
Comment 3 Lukáš Říha 2013-10-25 18:58:12 EDT
Created attachment 816301 [details]
File: core_backtrace
Comment 4 Lukáš Říha 2013-10-25 18:58:15 EDT
Created attachment 816302 [details]
File: dso_list
Comment 5 Lukáš Říha 2013-10-25 18:58:18 EDT
Created attachment 816303 [details]
File: environ
Comment 6 Lukáš Říha 2013-10-25 18:58:21 EDT
Created attachment 816304 [details]
File: limits
Comment 7 Lukáš Říha 2013-10-25 18:58:24 EDT
Created attachment 816305 [details]
File: maps
Comment 8 Lukáš Říha 2013-10-25 18:58:28 EDT
Created attachment 816306 [details]
File: open_fds
Comment 9 Lukáš Říha 2013-10-25 18:58:31 EDT
Created attachment 816307 [details]
File: proc_pid_status
Comment 10 Lukáš Říha 2013-10-25 18:58:34 EDT
Created attachment 816308 [details]
File: var_log_messages
Comment 11 Lukáš Říha 2013-10-25 18:58:47 EDT
Created attachment 816309 [details]
File: SCAN0006.JPG
Comment 12 Fiorenzo 2013-12-30 09:51:50 EST
Another user experienced a similar problem:

I simply tried to use YAGF with cuneiform but it crashed.

reporter:       libreport-2.1.10
backtrace_rating: 4
cmdline:        cuneiform -l eng -f text -o /home/kensh1n/.config/yagf/output.txt /home/kensh1n/.config/yagf/input.bmp
crash_function: average_inc
executable:     /usr/bin/cuneiform
kernel:         3.12.5-302.fc20.x86_64
package:        cuneiform-1.1.0-15.fc20
reason:         cuneiform killed by SIGFPE
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 13 Dmitrij S. Kryzhevich 2014-04-01 22:52:54 EDT
The problem is in the OCR core, can't fix myself amd upstream for cuneiform is dead. Closed.

Note You need to log in before you can comment on or make changes to this bug.