Bug 102363 - install chooses randomly between several possible iso images to install from
install chooses randomly between several possible iso images to install from
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-14 11:21 EDT by alex kramarov
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-14 12:43:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description alex kramarov 2003-08-14 11:21:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.1.4322)

Description of problem:
the latest beta has 1 AS cd, 1 WS cd, and 2 shared cds, put in an ISO directory 
like this :

taroon-i386-as-disc1.iso
taroon-i386-disc2.iso
taroon-i386-disc3.iso
taroon-i386-ws-disc1.iso

if you try to install it using nfs or harddrive installation from such a 
directory, that contains both AS and WS, you get one of the products installed, 
and for me it was not the one i intended (i wanted AS, and got WS - i didn't 
think that i had both As and WS cds in the directory). anaconda should detect 
such a condition, and at least tell you that it is trying to install "such and 
such" product. better yet, let the user choose. this is important, since later 
there will also be ES, so 3 products with 2 shared cds, one could create 3 
directories with simlinks to the nesessary iso for AS, ES and WS, but some 
filesystems do not support that ...


Version-Release number of selected component (if applicable):
stock of RHAS 3 beta 1

How reproducible:
Always

Steps to Reproduce:
1.copy all the isos from ftp.redhat.com of the latest beta
2.install using the nfs method
3.
    

Actual Results:  you get WS

Expected Results:  expected AS

Additional info:

of course, this may not be considered a bug, but a feature. for me it's 
problematic if anaconda can't handle such scenario.
Comment 1 Michael Fulbright 2003-08-14 12:36:05 EDT
If not already mentioned in the documentation and release notes, my
understanding is that you cannot mix ISOs as you are trying to do.
Comment 2 Jeremy Katz 2003-08-14 12:43:11 EDT
This is by design and is not going to change at the present time.  Please use
separate directories and either symlinks or hardlinks for the shared discs.

Note You need to log in before you can comment on or make changes to this bug.