Bug 1023635 - BUG: Bad page state in process chrome pfn:6b0e1f
BUG: Bad page state in process chrome pfn:6b0e1f
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-26 07:35 EDT by Mikhail
Modified: 2014-02-24 10:54 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-24 10:54:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (249.22 KB, text/plain)
2013-10-26 07:35 EDT, Mikhail
no flags Details

  None (edit)
Description Mikhail 2013-10-26 07:35:17 EDT
Created attachment 816388 [details]
dmesg output

Description of problem:

[13410.026912] BUG: Bad page state in process chrome  pfn:6b0e1f
[13410.026926] page:ffffea001ac387c0 count:16777216 mapcount:0 mapping:          (null) index:0x2
[13410.026928] page flags: 0x5ff00000000000()
[13410.026930] Modules linked in: fuse nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6t_REJECT xt_conntrack ebtable_nat ebtable_broute bridge stp llc ebtable_filter ebtables ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_mangle ip6table_security ip6table_raw ip6table_filter ip6_tables iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_mangle iptable_security iptable_raw bnep iTCO_wdt iTCO_vendor_support ppdev x86_pkg_temp_thermal coretemp kvm_intel kvm crc32_pclmul crc32c_intel ghash_clmulni_intel microcode btusb bluetooth rfkill snd_hda_codec_realtek serio_raw snd_hda_codec_hdmi snd_emu10k1 snd_util_mem snd_hda_intel snd_rawmidi snd_hda_codec snd_hwdep snd_ac97_codec snd_seq ac97_bus snd_seq_device emu10k1_gp r8169 gameport mii
[13410.026995]  snd_pcm i2c_i801 lpc_ich mfd_core shpchp snd_page_alloc snd_timer snd mei_me mei soundcore parport_pc parport acpi_cpufreq mperf binfmt_misc nfsd auth_rpcgss nfs_acl lockd sunrpc usb_storage i915 hid_logitech_dj i2c_algo_bit firewire_ohci drm_kms_helper sata_sil24 firewire_core drm crc_itu_t i2c_core video
[13410.027038] CPU: 7 PID: 7941 Comm: chrome Tainted: G        W    3.11.6-301.fc20.x86_64+debug #1
[13410.027040] Hardware name: Gigabyte Technology Co., Ltd. Z87M-D3H/Z87M-D3H, BIOS F8 08/03/2013
[13410.027042]  0000000000000001 ffff8806b5f15ab8 ffffffff817289cc ffffea001ac387c0
[13410.027055]  ffff8806b5f15ad0 ffffffff81725578 0000000000000000 ffff8806b5f15bb8
[13410.027059]  ffffffff81181e76 ffff8806b5f15af8 ffffffff81731a97 0000000000000002
[13410.027062] Call Trace:
[13410.027067]  [<ffffffff817289cc>] dump_stack+0x54/0x74
[13410.027079]  [<ffffffff81725578>] bad_page.part.55+0xcf/0xe8
[13410.027084]  [<ffffffff81181e76>] get_page_from_freelist+0x846/0x9a0
[13410.027088]  [<ffffffff81731a97>] ? _raw_spin_unlock+0x27/0x40
[13410.027091]  [<ffffffff811821a6>] __alloc_pages_nodemask+0x1d6/0xbd0
[13410.027095]  [<ffffffff811dd77e>] ? rcu_read_unlock+0x2e/0x70
[13410.027098]  [<ffffffff811e461b>] ? __mem_cgroup_try_charge+0x5fb/0xf10
[13410.027101]  [<ffffffff811e43c8>] ? __mem_cgroup_try_charge+0x3a8/0xf10
[13410.027103]  [<ffffffff811876a1>] ? release_pages+0x1f1/0x280
[13410.027107]  [<ffffffff811c6dda>] alloc_pages_vma+0x9a/0x140
[13410.027111]  [<ffffffff811a527b>] handle_pte_fault+0x6cb/0x9b0
[13410.027113]  [<ffffffff811defc5>] ? __mem_cgroup_count_vm_event+0x5/0x2c0
[13410.027116]  [<ffffffff811a63a5>] handle_mm_fault+0x2a5/0x5c0
[13410.027119]  [<ffffffff817367e8>] __do_page_fault+0x158/0x590
[13410.027122]  [<ffffffff810ac95f>] ? finish_task_switch+0x3f/0x120
[13410.027126]  [<ffffffff810e933d>] ? trace_hardirqs_on+0xd/0x10
[13410.027129]  [<ffffffff81731b9c>] ? _raw_spin_unlock_irq+0x2c/0x50
[13410.027131]  [<ffffffff810ac99c>] ? finish_task_switch+0x7c/0x120
[13410.027133]  [<ffffffff810ac95f>] ? finish_task_switch+0x3f/0x120
[13410.027137]  [<ffffffff8137a90d>] ? trace_hardirqs_off_thunk+0x3a/0x3c
[13410.027140]  [<ffffffff81736c2e>] do_page_fault+0xe/0x10
[13410.027142]  [<ffffffff81732b48>] page_fault+0x28/0x30



[mikhail@localhost ~]$ lspci
00:00.0 Host bridge: Intel Corporation 4th Gen Core Processor DRAM Controller (rev 06)
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)
00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 (rev d4)
00:1c.2 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #3 (rev d4)
00:1c.3 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d4)
00:1c.4 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #5 (rev d4)
00:1f.0 ISA bridge: Intel Corporation Z87 Express LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller (rev 04)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)
03:00.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 41)
04:01.0 Multimedia audio controller: Creative Labs SB Audigy (rev 04)
04:01.1 Input device controller: Creative Labs SB Audigy Game Port (rev 04)
04:01.2 FireWire (IEEE 1394): Creative Labs SB Audigy FireWire Port (rev 04)
05:00.0 RAID bus controller: Silicon Image, Inc. SiI 3132 Serial ATA Raid II Controller (rev 01)



[mikhail@localhost ~]$ lsusb
Bus 002 Device 002: ID 2109:0811  
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 007: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Bus 001 Device 009: ID 05e3:0723 Genesys Logic, Inc. GL827L SD/MMC/MS Flash Card Reader
Bus 001 Device 006: ID 1a40:0101 Terminus Technology Inc. Hub
Bus 001 Device 010: ID 1bbb:019b T & A Mobile Phones 
Bus 001 Device 005: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 008: ID 04d9:1503 Holtek Semiconductor, Inc. Shortboard Lefty
Bus 001 Device 004: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 003: ID 1a40:0201 Terminus Technology Inc. FE 2.1 7-port Hub
Bus 001 Device 002: ID 2109:0811  
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Comment 1 Mladen Gogala 2013-11-17 20:23:30 EST
I have the same problem with the kernel 3.11.8 in Fedora 19:

Nov 17 20:11:24 medo kernel: [26146.937916] BUG: Bad page state in process oracle  pfn:2b2e3c
Nov 17 20:11:24 medo kernel: [26146.937935] page:ffffea000acb8f00 count:0 mapcount:5 mapping:          (null) index:0x2
Nov 17 20:11:24 medo kernel: [26146.937954] page flags: 0x5ff00000008000(tail)
Nov 17 20:11:24 medo kernel: [26146.937972] Modules linked in: ipheth vboxpci(OF) vboxnetadp(OF) vboxnetflt(OF) vboxdrv(OF) nvidia(POF) kvm_amd uvcvideo videobuf2_vmalloc videobuf2_memops snd_hda_codec_via snd_hda_intel snd_hda_codec videobuf2_core videodev media snd_usb_audio snd_usbmidi_lib snd_hwdep snd_rawmidi snd_seq xfs libcrc32c kvm ppdev r8169 snd_seq_device snd_pcm edac_core mii snd_page_alloc snd_timer snd soundcore parport_pc shpchp sp5100_tco parport wmi microcode serio_raw k10temp edac_mce_amd i2c_piix4 i2c_core asus_atk0110 acpi_cpufreq mperf uinput binfmt_misc usb_storage ata_generic pata_acpi pata_atiixp
Nov 17 20:11:24 medo kernel: [26146.938030] CPU: 3 PID: 12958 Comm: oracle Tainted: PF   B    C O 3.11.8-200.fc19.x86_64 #1
Nov 17 20:11:24 medo kernel: [26146.938034] Hardware name: System manufacturer System Product Name/M4A88T-M, BIOS 2403    12/23/2010
Nov 17 20:11:24 medo kernel: [26146.938037]  0000000000000005 ffff8802edf21d30 ffffffff8164781b ffffea000acb8f00
Nov 17 20:11:24 medo kernel: [26146.938044]  ffff8802edf21d48 ffffffff81644a6e 000000000000003b ffff8802edf21d90
Nov 17 20:11:24 medo kernel: [26146.938051]  ffffffff81143825 ffffea000acc0000 0000000000000000 ffffea000acb8000
Nov 17 20:11:24 medo kernel: [26146.938057] Call Trace:
Nov 17 20:11:24 medo kernel: [26146.938065]  [<ffffffff8164781b>] dump_stack+0x45/0x56
Nov 17 20:11:24 medo kernel: [26146.938071]  [<ffffffff81644a6e>] bad_page.part.59+0xcf/0xe8
Nov 17 20:11:24 medo kernel: [26146.938079]  [<ffffffff81143825>] free_pages_prepare+0x165/0x170
Nov 17 20:11:24 medo kernel: [26146.938086]  [<ffffffff81144624>] __free_pages+0x34/0x80
Nov 17 20:11:24 medo kernel: [26146.938092]  [<ffffffff8117f3a2>] update_and_free_page+0x92/0xe0
Nov 17 20:11:24 medo kernel: [26146.938098]  [<ffffffff8117f4b1>] free_pool_huge_page+0xc1/0xe0
Nov 17 20:11:24 medo kernel: [26146.938105]  [<ffffffff8117fac5>] set_max_huge_pages.part.48+0x135/0x1f0
Nov 17 20:11:24 medo kernel: [26146.938112]  [<ffffffff8117fef3>] hugetlb_sysctl_handler_common+0x133/0x150
Nov 17 20:11:24 medo kernel: [26146.938118]  [<ffffffff811806ce>] hugetlb_sysctl_handler+0x1e/0x20
Nov 17 20:11:24 medo kernel: [26146.938125]  [<ffffffff81216583>] proc_sys_call_handler+0xb3/0xc0
Nov 17 20:11:24 medo kernel: [26146.938132]  [<ffffffff812165a4>] proc_sys_write+0x14/0x20
Nov 17 20:11:24 medo kernel: [26146.938139]  [<ffffffff811a82bd>] vfs_write+0xbd/0x1e0
Nov 17 20:11:24 medo kernel: [26146.938146]  [<ffffffff811a8cf9>] SyS_write+0x49/0xa0
Nov 17 20:11:24 medo kernel: [26146.938153]  [<ffffffff81656a19>] system_call_fastpath+0x16/0x1b

root@medo mgogala]# uname -a
Linux medo.home.com 3.11.8-200.fc19.x86_64 #1 SMP Wed Nov 13 16:29:59 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Comment 2 Mladen Gogala 2013-11-17 20:27:20 EST
Here is my lspci and lsusb:

00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] RS880 Host Bridge
00:02.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] RS780 PCI to PCI bridge (ext gfx port 0)
00:0a.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] RS780/RS880 PCI to PCI bridge (PCIE port 5)
00:11.0 SATA controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 SATA Controller [IDE mode]
00:12.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:12.1 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0 USB OHCI1 Controller
00:12.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:13.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:13.1 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0 USB OHCI1 Controller
00:13.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 SMBus Controller (rev 3c)
00:14.1 IDE interface: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 IDE Controller
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 LPC host controller
00:14.4 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 PCI to PCI Bridge
00:14.5 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Address Map
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Link Control
01:00.0 VGA compatible controller: NVIDIA Corporation NV44 [Quadro NVS 285] (rev a1)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)


Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 058f:6377 Alcor Micro Corp. Multimedia Card Reader
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 046d:0802 Logitech, Inc. Webcam C200
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 046d:c31c Logitech, Inc. Keyboard K120 for Business
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 1130:1620 Tenx Technology, Inc. 
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Comment 3 Mladen Gogala 2013-12-07 16:48:07 EST
The problem happens when I allocate huge pages for oracle and de-allocate them on exit. The problem happens during the execution of the following command:

echo 0 > /proc/sys/vm/nr_hugepages

Here is the entire script to start the Oracle service:

#! /bin/sh
#
# oracle: stop and start Oracle RDBMS
#
# chkconfig: - 92 5
# description: 

### BEGIN INIT INFO
# Default-Start:     2 3 4 5
# Default-Stop:
# Short-Description: Start and stop Oracle instances
### END INIT INFO

set -am
PATH=/sbin:/usr/sbin:/bin:/usr/bin
ORACLE_HOME=/oracle/product/12.1.0.1/dbhome1
case $1 in
start)
        echo 2536 > /proc/sys/vm/nr_hugepages
        su - oracle -c "dbstart $ORACLE_HOME"
        touch /var/lock/subsys/oracle
        ;;
stop)
        su - oracle -c "dbshut $ORACLE_HOME"
        echo 0 > /proc/sys/vm/nr_hugepages
        rm -f /var/lock/subsys/oracle
        ;;
*)      echo "$0 [start|stop]"
        ;;
esac;


Transparent huge pages are disabled:

[root@medo kernel]# cat /sys/kernel/mm/transparent_hugepage/enabled
always madvise [never]

I tried with transparent huge pages enabled, but it makes no difference. Basically, something is broken in the page de-allocation mechanism.
Comment 4 Justin M. Forbes 2014-02-24 08:58:13 EST
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 20 kernel bugs.

Fedora 20 has now been rebased to 3.13.4-200.fc20.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 5 Mladen Gogala 2014-02-24 09:38:31 EST
We're good, the kernel that I'm using currently does not have that problem:

Linux medo.home.com 3.13.3-201.fc20.x86_64 #1 SMP Fri Feb 14 19:08:32 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

The kernel release 3.13.4 is still in the testing repo and I will install it when it becomes available through the normal channels.

Note You need to log in before you can comment on or make changes to this bug.