Bug 1023644 - Miss disable_puppet function in puppet_page.py
Miss disable_puppet function in puppet_page.py
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
:
Depends On: 1023378
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-26 08:25 EDT by haiyang,dong
Modified: 2014-12-08 10:08 EST (History)
17 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-8.el6
Doc Type: Bug Fix
Doc Text:
There was no way to stop the puppet service. A disable_puppet function has been added in puppet_page.py to stop puppet service and remove related configuration information from "/etc/puppet/puppet.conf".
Story Points: ---
Clone Of: 1023378
Environment:
Last Closed: 2014-01-21 14:36:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20538 None None None Never
Red Hat Product Errata RHBA-2014:0033 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2014-01-21 19:14:30 EST

  None (edit)
Description haiyang,dong 2013-10-26 08:25:32 EDT
+++ This bug was initially created as a clone of Bug #1023378 +++

Description of problem:
Need add disable_puppet function in puppet_page.py to stop puppet service and remove related
configuration info from "/etc/puppet/puppet.conf"


Version-Release number of selected component (if applicable):
ovirt-node-iso-3.1.0-0.999.1132.el6.iso
ovirt-node-plugin-puppet-3.1.0-0.999.20131024005255gitc1886e2.el6.noarch.rpm

How reproducible:
100%

Steps to Reproduce:

Actual results:


Expected results:


Additional info:
Comment 1 haiyang,dong 2013-10-26 08:26:15 EDT
Could reproduce this issue in downstream:
rhevh-6.5-20131024.1.0.iso
ovirt-node-plugin-puppet-3.0.1-6.el6.noarch.rpm

so need clone it from upstream to track it in rhev-h
Comment 4 haiyang,dong 2013-12-17 05:35:07 EST
Test version:
ovirt-node-3.0.1-9.el6_5.noarch.rpm
rhevh-6.5-20131213.0.0.iso

Unslect "Enable Puppet" in puppet_page.py to disable puppet will stop puppet service and remove related
configuration info from "/etc/puppet/puppet.conf"

[root@dhcp-8-144 admin]# service puppet status
puppetd is stopped
[root@dhcp-8-144 admin]# cat /etc/puppet/puppet.conf |more
[main]
#    server = ""
#    certname = ""
    # The Puppet log directory.
    # The default value is '$vardir/log'.
    logdir = /var/log/puppet

    # Where Puppet PID files are kept.
    # The default value is '$vardir/run'.
    rundir = /var/run/puppet

    # Where SSL certificates are kept.
    # The default value is '$confdir/ssl'.
    ssldir = $vardir/ssl


so this bug has been fixed on ovirt-node-3.0.1-9.el6_5, after the status of this bug changed into "ON_QA", I will verify it.
Comment 5 haiyang,dong 2013-12-19 21:08:22 EST
According to comment 4 , change the status into "verified"
Comment 6 Cheryn Tan 2014-01-08 00:37:04 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:
https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes

Thank you for your help.
Comment 7 haiyang,dong 2014-01-16 04:27:29 EST
Also this bug was fixed in the follow version:
rhevh-6.5-20140110.1
ovirt-node-3.0.1-16.el6_5.noarch
Comment 9 errata-xmlrpc 2014-01-21 14:36:01 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.