Bug 102366 - Isapnp Card 'CS4236B' not correctly configured by kudzu during installation
Summary: Isapnp Card 'CS4236B' not correctly configured by kudzu during installation
Status: CLOSED DUPLICATE of bug 115885
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: kudzu   
(Show other bugs)
Version: beta1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-14 15:38 UTC by Denice
Modified: 2014-03-17 02:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:58:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Denice 2003-08-14 15:38:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
This is an OptiPlex GX1 machine with on-board sound: CS4236.  Kudzu does not set
up a correct modules.conf file.  One needs to run sndconfig to get a
configuration that works. 

On a fresh installation in /root/install.log.syslog we see:

# grep kudzu install.log.syslog
<13>Aug 14 16:40:41 kudzu: linked /dev/mouse to /dev/psaux
<13>Aug 14 16:40:43 kudzu: ran mouseconfig for psaux
<13>Aug 14 16:40:43 kudzu: aliased sound-slot-2 as ad1848
<13>Aug 14 16:40:43 kudzu: aliased usb-controller as usb-uhci

and have in /etc/modules.conf:
alias sound-slot-2 ad1848
post-install sound-slot-2 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1
|| :
pre-remove sound-slot-2 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :

After running sndconfig, we get in /etc/modules.conf:
alias sound-slot-0 cs4232
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1
|| :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :
options sound dmabuf=1
alias synth0 opl3
options opl3 io=0x388
options cs4232 isapnp=1

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install Severn
2. try playing any .wav sound
3.
    

Actual Results:  You must run sndconfig to make sound work for this hardware.

Expected Results:  kudzu on installation should have configured this card.

Additional info:

kudzu will finally set up the sound card correctly if you rename
/etc/sysconfig/hwconf and rerun kudzu from the commandline.  Also note that it
generates yet another, different modules.conf file:

alias sound-slot-0 cs4232
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1
|| :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :
options sound dmabuf=1
alias synth0 opl3
options opl3 io=0x388
options cs4232 isapnp=1
alias sound-slot-2 ad1848
post-install sound-slot-2 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1
|| :
pre-remove sound-slot-2 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :

Comment 1 Denice 2003-08-14 15:40:50 UTC
Note, I forgot to add, this looks rather similar to this bug:

 https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=88103


Comment 2 Bill Nottingham 2004-09-30 04:53:09 UTC

*** This bug has been marked as a duplicate of 115885 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:58:06 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.