Bug 1023681 - [REGRESSION] Ellipses are centered vertically
[REGRESSION] Ellipses are centered vertically
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: terminus-fonts (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Hans Ulrich Niedermann
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-26 21:13 EDT by Ben Boeckel
Modified: 2014-05-17 19:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-17 19:49:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Ellipses with 4.38-2.fc20 (2.52 KB, image/png)
2013-11-18 21:12 EST, Ben Boeckel
no flags Details

  None (edit)
Description Ben Boeckel 2013-10-26 21:13:53 EDT
Description of problem:
Using "xft:Terminus:pixelsize=12" for my terminal results in vertically-centered ellipses characters (…). Using "-xos4-terminus-medium-r-normal-*-14-*-*-*-*-*-*-*" also fails whereas "-xos4-terminus-medium-r-normal-*-16-*-*-*-*-*-*-*" works. It used to look fine.

Version-Release number of selected component (if applicable):
levien-inconsolata-fonts-1.01-9.fc20.noarch

ISTR this working not too long ago, but looking at inconcolata's yum history, it might be something else at work here. The 1.01-8 build (installed February) was definitely fine. The 1.01-9 was installed August 6. I'm also seeing Japanese characters rendering as something as other than 2-wide boxes, which I would not expect as new from a simple 1.01 rebuild. What else could affect this?
Comment 1 Kevin Fenzi 2013-10-27 13:21:04 EDT
You mention terminus, but this is filed against inconsolata? 

Which font are you seeing this in?

There's really been 0 change in the inconsolata font. It's the same source since 2009 or so.
Comment 2 Ben Boeckel 2013-10-27 18:38:38 EDT
Oops...yeah. Wires crossed here. I used Inconsolata for the longest time and moved over to Terminus in March.

Anyways, looking for the right package, I see:

Feb 24 20:38:49 Updated: terminus-fonts-4.36-4.fc19.noarch
Feb 24 20:40:32 Updated: terminus-fonts-console-4.36-4.fc19.noarch
Aug 06 23:06:32 Updated: terminus-fonts-4.36-5.fc20.noarch
Aug 15 22:21:35 Updated: terminus-fonts-console-4.36-5.fc20.noarch
Sep 16 20:59:38 Updated: terminus-fonts-4.38-1.fc21.noarch
Sep 16 20:59:39 Updated: terminus-fonts-console-4.38-1.fc21.noarch

And the 4.38 update is a plausible time frame. I hope the component change works properly (using JS since the drop down takes aaaages to render).
Comment 3 Hans Ulrich Niedermann 2013-11-18 18:27:56 EST
I just tried "….…." in xterm and gnome-terminal with terminus-fonts-4.38-2.fc20.noarch and have seen no such problem. The dots all lined up.

Will try again after the next reboot.
Comment 4 Ben Boeckel 2013-11-18 21:12:22 EST
Created attachment 825872 [details]
Ellipses with 4.38-2.fc20

This is what I see with 4.38-2.fc20 in urxvt256cc.
Comment 5 Hans Ulrich Niedermann 2013-11-21 06:28:25 EST
I still cannot reproduce the issue.

The ellipses in "….…." look good here with

    terminus-fonts-4.38-2.fc20.noarch
    rxvt-unicode-9.19-1.fc20.x86_64
    rxvt-unicode-256color-9.19-1.fc20.x86_64

when I run

    $ urxvt -fn xft:Terminus:pixelsize=12 &
    $ urxvt256c -fn xft:Terminus:pixelsize=12 &
    $ urxvt256cc -fn xft:Terminus:pixelsize=12 &
    [3] 10592
    unable to connect to the rxvt-unicode daemon: No such file or directory
    [3]+  Exit 2                  urxvt256cc -fn xft:Terminus:pixelsize=12
    $ urxvt256cd &
    rxvt-unicode daemon listening on /home/ndim/.urxvt/urxvtd-infty.
    $ urxvt256cc -fn xft:Terminus:pixelsize=12 &
    [5] 12374
    $
Comment 6 Ben Boeckel 2013-11-21 12:34:33 EST
Ah ha. If the font is set with `-fn`, it looks fine. I have this in my ~/.Xdefaults:

    URxvt.font:              xft:Terminus:pixelsize=12

Is there some weird code path the X resources go through that -fn doesn't (or vice versa)?
Comment 7 Hans Ulrich Niedermann 2013-11-21 14:26:34 EST
I just added an ~/.Xdefaults file and set URxvt.font.

Still no shifted ellipses.
Comment 8 Ben Boeckel 2013-11-21 14:46:29 EST
Did you run xrdb -merge ~/.Xdefaults to update the resources for the current session? Only new instances after running that will get the new data. I'll try with a fresh user profile when I get the chance.
Comment 9 Hans Ulrich Niedermann 2013-11-21 16:03:15 EST
Yepp. Tried with and without the "xrdb -merge".

I'll try a fresh user profile as well.
Comment 10 Ben Boeckel 2013-11-30 12:30:56 EST
I'm seeing things are better in Rawhide with:

terminus-fonts-4.38-3.fc21.noarch

I'll test F20 at work on Monday.
Comment 11 Ben Boeckel 2013-12-02 10:04:14 EST
Now it works with terminus-fonts-4.38-2.fc20.noarch… I wonder if the -2 update did work, just that I hadn't restarted X for a while and the bad glyph was cached (never did get around to testing a new session).
Comment 12 Ben Boeckel 2013-12-02 20:59:32 EST
Oops. Nope. *Bold* ellipses are fine. Regular ones are still weird.
Comment 13 Ben Boeckel 2014-05-17 19:49:19 EDT
OK, so I ended up nuking my font caches and it's back to normal (once new machines started showing up as OK, I figured it was cached somewhere). I guess one of the releases had a bad glyph and I just happened to hit the jackpot.

Note You need to log in before you can comment on or make changes to this bug.