Bug 1023746 - Yumex Blanks Dialog On Second Process
Yumex Blanks Dialog On Second Process
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
20
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
: 1036371 1045551 1046434 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-27 11:30 EDT by KitchM
Modified: 2014-03-08 23:35 EST (History)
14 users (show)

See Also:
Fixed In Version: yumex-3.0.14-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-26 23:13:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Blank dialog window and frozen program (100.56 KB, image/png)
2013-10-27 11:30 EDT, KitchM
no flags Details
Nextgen won't close (6.43 KB, image/png)
2014-01-28 10:30 EST, KitchM
no flags Details
Screenshot of Yumex in action with blank dialog (194.12 KB, image/png)
2014-02-22 21:01 EST, D. Charles Pyle
no flags Details
Screenshot of Yumex in action with blank dialog at the end, while checking for updates after an update. (112.52 KB, image/png)
2014-02-26 05:51 EST, D. Charles Pyle
no flags Details

  None (edit)
Description KitchM 2013-10-27 11:30:31 EDT
Created attachment 816534 [details]
Blank dialog window and frozen program

Description of problem:
Yumex can only handle one transaction before being closed or it will blank any dialog box and freeze.


Version-Release number of selected component (if applicable):
3.0.13


How reproducible:
Always


Steps to Reproduce:
1.Start Yumex
2.Select some updates
3.Enter password
4.Process updates
5.Go back to select more updates
6.Enter password again
7.Blank dialog window pops up
8.Must use Task Manager to close program

Actual results:
Unusable

Expected results:
Should not stop working


Additional info:
Too many problems have developed since the last major upgrade
Comment 1 Tim Lauridsen 2013-11-05 00:54:16 EST
I could re-produce when running 3 transactions in a row.
very strange the dialog is working but not painting right, if you click where the buttons are supposed to be, they are working, so yumex is not hanging, the dialog is just not painted right.
Comment 2 Wolfgang Ulbrich 2013-11-06 18:31:18 EST
I noticed this issue since yumex-3.0.11 .
It happens on several machines with f19/f20/rawhide, with several desktops (mate, cinnamon, gnome) and with several graphic drivers (intel, nvidia, nouveau, qxl (qemu)).
Hope you found a solution because we decided to use yumex as default package manager for mate desktop.
Comment 3 KitchM 2013-11-20 09:12:38 EST
Still happening on latest under Xfce 4.10.1.
Comment 4 The Old Man 2013-11-30 11:17:50 EST
Still there

yumex 3.0.13
Fedora 19 x86_64

Once 2nd update dialog gets blank, yumex still works (cicle with 'tab' and hit enter, 'something' shall happen depending which invisible button is selected),
but all dialog windows shall be blank (window title is visable though).

To close yumex nicely:

Press 'Tab' 3 times, hereby blindly selecting button 'OK' (2 times = Cancel), 
Hit 'Enter', second install/update starts.
Gui returns in 'starting' state. 
Close Yumex the way you are used to.
Comment 5 Tim Lauridsen 2013-12-27 11:53:40 EST
*** Bug 1046434 has been marked as a duplicate of this bug. ***
Comment 6 Tim Lauridsen 2013-12-27 11:55:13 EST
*** Bug 1045551 has been marked as a duplicate of this bug. ***
Comment 7 Tim Lauridsen 2013-12-27 12:01:21 EST
It must be related to some GTK some how, all the widgets is working in the dialog, but is just invisible, but if you are pressing where the button is supposed to be shown, they work when you click them.
I have done some intensive test of hide/showing the dialog, but can not make the dialog widgets become invisible, but it is easy to make it happen in yumex
Comment 8 Knut Torgersen 2014-01-02 15:11:20 EST
I have this error on 3.0.13 on two PCs running XFCE, BUT if I switch to the Cinnamon environment it works just fine.
Comment 9 Max Fomin 2014-01-27 07:01:54 EST
I also have the same error every time i use Yumex.

-Yumex version 3.0.13
-Russian_Fedora_Remix-20x86_64
-Gnome-shell 3.10.3
-yum version 3.4.3

I hope you find the solution.
Comment 10 Tim Lauridsen 2014-01-27 07:15:45 EST
I have not been able to find a way to fix this issue yet, it is very strange

you can try yumex-nextgen, there dont have this issue

http://copr-fe.cloud.fedoraproject.org/coprs/timlau/yumex-nextgen/
Comment 11 Max Fomin 2014-01-27 08:21:11 EST
Thank you, Tim!
It works good for me.
Thanks a lot!!!
Comment 12 KitchM 2014-01-28 10:29:24 EST
Tried yumex-nextgen and it has its own problems. The interface is a little strange, and it fails to close properly.  Trying to restart shows attached error message which indicates it is still running.

After attempting to find all related tasks in the task manager and attempting to close them, it still thought it was running.  This program is not properly self-contained.

I think it is better to have the regular yumex programmed correctly.

These two programs clearly display the real problems in programming.  If a person does not understand the current state of interaction between OS and DE and WM and other programming languages, he should not be attempting the programming.  This is the single biggest reason why we have too many computer problems.
Comment 13 KitchM 2014-01-28 10:30:07 EST
Created attachment 856675 [details]
Nextgen won't close
Comment 14 Max Fomin 2014-01-28 11:14:23 EST
(In reply to KitchM from comment #13)
> Created attachment 856675 [details]
> Nextgen won't close

It closes with "Quit" button.
Comment 15 Tim Lauridsen 2014-01-28 11:40:52 EST
You must close 'yumex-nextgen' with the quit button
'X' just hides the window, you must press the shield icon in the notification area to show the window again.

if there is any issue, you can run 'yumex-nextgen --exit' to cleanup running jobs
Comment 16 dominique 2014-01-28 11:49:11 EST
I test yumex-nextgen and for me it's work perfectly, and I think it's more faster than yumex.

But it is not yet translated, I attempt translate in french but the pot file is not up to date.

Can you : 
-Update the translation
-and put the translation on transifex 

Good job.
Comment 17 Wolfgang Ulbrich 2014-01-28 12:02:51 EST
@ Tim
yes quit button is working, but yumex-nextgen doesn't support the quit button from windows-manager like marco (Mate), metacity...
I didn't test it with xfce-windows manager but i quess it's also broken there.
I know in gnome using a windows-decorator is obsolete, but gnome will come with gnome-software.
So imo, yumex-gen should be also focused to work with traditional desktops.
Comment 18 KitchM 2014-01-28 19:48:16 EST
@Max Fomin,
No, it doesn't.

@Tim Lauridsen,
That did nothing.

"Not ready for primetime."
Comment 19 Tim Lauridsen 2014-01-29 03:13:53 EST
(In reply to Wolfgang Ulbrich from comment #17)
> @ Tim
> yes quit button is working, but yumex-nextgen doesn't support the quit
> button from windows-manager like marco (Mate), metacity...
> I didn't test it with xfce-windows manager but i quess it's also broken
> there.
> I know in gnome using a windows-decorator is obsolete, but gnome will come
> with gnome-software.
> So imo, yumex-gen should be also focused to work with traditional desktops.

Ok, I see your point, selecting 'close' from the window icon menu, just hides yumex and don't close it, that is not so logic :-)

I will change the way "close" and "X" works so they close yumex if no transaction is been executed.

I run XFCE myself and the prime focus will be xfce, lxde, mate, cinnemon
But it will be useful for gnome users to, gnome-software only shows GUI applications, not all the other stuff available like icons, desktop, tui applications.
Comment 20 Tim Lauridsen 2014-01-29 03:20:33 EST
(In reply to KitchM from comment #18)
> @Max Fomin,
> No, it doesn't.
> 

The quit button on yumex-nextgen toolbar will close yumex
Right click on the shield notification icon an select quit will close yumex too.

> @Tim Lauridsen,
> That did nothing.

yumex-nextgen --exit will close yumex jobs, running in the background 
and then you can start yumex-nextgen, without

> "Not ready for primetime."

It is not released for primetime yet, but it very useful when you learn to use it :)
Comment 21 Tim Lauridsen 2014-01-29 03:23:41 EST
(In reply to dominique from comment #16)
> I test yumex-nextgen and for me it's work perfectly, and I think it's more
> faster than yumex.
> 
> But it is not yet translated, I attempt translate in french but the pot file
> is not up to date.
> 
> Can you : 
> -Update the translation
> -and put the translation on transifex 
> 
> Good job.

Thanks.
I now the translation stuff is not perfect yet, but I will look into it soon and get it into transifex, but I has been waiting until the strings was stable, to not waste the time of the translators.
Comment 22 Wolfgang Ulbrich 2014-01-29 11:05:12 EST
(In reply to Tim Lauridsen from comment #19)
> I run XFCE myself and the prime focus will be xfce, lxde, mate, cinnemon
+1
Comment 23 KitchM 2014-01-29 11:24:48 EST
@Tim Lauridson,
You can say it does all day long, and I can say it doesn't all day long.  What does that get you?  You may be correct in your situation, but you're certainly not in mine, which was the whole point.  Sorry if I didn't make that clear enough.
Comment 24 KitchM 2014-01-29 11:36:54 EST
Okay, since I'm tired of it not closing after three days, I had to jump thru hoops to get it closed.  I used the yumex-nextgen --exit command by opening a terminal window, pasting it in and pressing Enter (for those who don't know how).

Then, just for kicks before removing it, I started it again.  The program does not remember its last window size.  If one selects the maximize button, it goes to an intermediate size off screen (hiding the X).  Selecting the maximize yet again gets it finally to go full screen.

It automatically searched for and listed the available updates.  However, there was no button to select them all.  Also, the hover-over did not fully work; particularly on the tiny little unrecognizable icons on the bottom left side.

This time the systray icon worked to quit.

This program does not work with standard conventions.  Therefore, the only thing one can assume is that it is not being programmed in a standard manner.  There really isn't any other option.

One must never program for a particular DE.  It should be cross-platform compatible, and it should work the same way in all environments and with the expected behavior we have all come to know and love.

Sorry, but it just isn't as good as the regular yumex.
Comment 25 Tim Lauridsen 2014-01-29 12:52:57 EST
(In reply to KitchM from comment #23)
> @Tim Lauridson,
> You can say it does all day long, and I can say it doesn't all day long. 
> What does that get you?  You may be correct in your situation, but you're
> certainly not in mine, which was the whole point.  Sorry if I didn't make
> that clear enough.

I can't solve issues, I can't reproduce
Comment 26 Tim Lauridsen 2014-01-29 13:26:21 EST
(In reply to KitchM from comment #24)
> The program
> does not remember its last window size.  If one selects the maximize button,
> it goes to an intermediate size off screen (hiding the X).  Selecting the
> maximize yet again gets it finally to go full screen.

please add a RFE for saving windows size  & position here:
https://github.com/timlau/yumex/issues
please add info about DE and you screen resolution.

> 
> It automatically searched for and listed the available updates.  However,
> there was no button to select them all.  Also, the hover-over did not fully
> work; particularly on the tiny little unrecognizable icons on the bottom
> left side.
> 

Add a issue about no tooltip text for lower left buttons.
the icons is the same size as the ones in yumex, just located to the left, instead of the right

> This program does not work with standard conventions.  Therefore, the only
> thing one can assume is that it is not being programmed in a standard
> manner.  There really isn't any other option.

I don't follow any standard conventions, I try to think of box and design the gui for my personal preferences and I don't want to waste screenspace on thing I dont think is needed.

> One must never program for a particular DE.  It should be cross-platform
> compatible, and it should work the same way in all environments and with the
> expected behavior we have all come to know and love.
> 

I dont program to a special DE, It should work on all DE's, but I only test on the DE's that I use, Gnome is the only one there can be roblematic because the dont show notification icons in the panal like all other DE, but that is a gnome issue, not a yumex issue.

> Sorry, but it just isn't as good as the regular yumex.

yumex-nextgen is not complete yet, it is work in progress, but constuctive feedback can help polish the rough corners.

Remember yumex is a hobby project, done in my limited spare time, nobody pays me to do it, I do it just for fun :)
Comment 27 KitchM 2014-01-29 14:25:53 EST
That's why I cannot recommend it.  It's not really ready for beta release.
Comment 28 Knut Torgersen 2014-01-29 17:43:58 EST
Pardon me for being a party pooper and possibly speaking out of line, but wouldn't the discussion on yumex NEXTGEN be better off under a different case no...?
Comment 29 dominique 2014-02-04 01:05:08 EST
Hi Tim
For test I made an fr.po by updating the pot file, and made an "make update-po".
There is one problem : 

In pot file (and fr.po) I can see translatable string of /src/yumex.ui, and translate them, but after rebuild yumex-nextgen the /src/yumex.ui strings stay in english, the other strings in other files are translate.

I search on the web, but I can't see where is the error (or omission).
Comment 30 Tim Lauridsen 2014-02-21 01:32:52 EST
*** Bug 1036371 has been marked as a duplicate of this bug. ***
Comment 31 KitchM 2014-02-21 11:58:36 EST
Problem still exists with latest release.

It makes if very  difficult to know what is going on when something like a GBG check fails and one must run the install again.  There simply isn't anything to see without a restart of the whole program.
Comment 32 D. Charles Pyle 2014-02-22 21:01:47 EST
Created attachment 866524 [details]
Screenshot of Yumex in action with blank dialog

This business of blank dialogs still is occurring on Rawhide.  One can work around these issues in the meantime by remembering where the buttons are located and clicking there.  I have found that I can still do updates with Yumex as it is but would prefer to see the buttons.  Even though I cannot see them when Yumex is run a second time to do updates within the same few minutes, I still can click them and run the process.
Comment 33 Knut Torgersen 2014-02-23 06:06:06 EST
What happens if you

a) completely re-initialize all controls
b) make the yumex restart itself

What happens on startup that doesn't on a second pass?

No, I did not look at the source before asking. ;-)
Comment 34 KitchM 2014-02-23 10:29:48 EST
What do you mean by "re-initialize all controls"?  What are controls?  What is re-initialize?

How can one make ymex restart itself?  Shut it down and start it up?  My personal experience is that the problem goes away whenever the program is restarted.

It is interesting that you mention looking at the source code.  I wonder if users must be programmers to use this software.  Is that a prerequisite? ;)  I hope not.
Comment 35 Lixian Huang 2014-02-25 08:54:13 EST
Hey, guys! 

I think this issue is caused by the "update_tray_icon" function of "class StatusIcon", it seems the yumex tray icon will take over the current window focus. And this will make the dialog lost focusing, the program considers the dialog is invisible.   

Unfortunately, I don't know how to fix it perfectly, but add a workaround patch. This patch will not update the status of tray icon whenever doing the dialog show/hide action.


Here is the link of the patch:

http://www.buluoos.com/pub/release/buluoos/3.0/src/gnome/yumex-3.0.13_hack_issue_blanks_dialog_on_second_process.patch
Comment 36 Tim Lauridsen 2014-02-25 09:41:55 EST
(In reply to Lixian Huang from comment #35)
> Hey, guys! 
> 
> I think this issue is caused by the "update_tray_icon" function of "class
> StatusIcon", it seems the yumex tray icon will take over the current window
> focus. And this will make the dialog lost focusing, the program considers
> the dialog is invisible.   
> 
> Unfortunately, I don't know how to fix it perfectly, but add a workaround
> patch. This patch will not update the status of tray icon whenever doing the
> dialog show/hide action.
> 
> 
> Here is the link of the patch:
> 
> http://www.buluoos.com/pub/release/buluoos/3.0/src/gnome/yumex-3.0.
> 13_hack_issue_blanks_dialog_on_second_process.patch

Thanks a lot, look like you have found what is triggering the issue.
you patch removes the issues, I will find the right way, to solve it without 
removing the status icon integration
Comment 37 Tim Lauridsen 2014-02-25 09:55:14 EST
Looks like a little change in the order of how i do things solves the issue

https://github.com/timlau/yumex/commit/2d8424500042459f5a7b1ccc66d2e42eabd590df

I will make a new release very soon
Comment 38 Fedora Update System 2014-02-26 00:38:29 EST
yumex-3.0.14-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/yumex-3.0.14-1.fc20
Comment 39 Fedora Update System 2014-02-26 00:38:42 EST
yumex-3.0.14-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/yumex-3.0.14-1.fc19
Comment 40 lnie 2014-02-26 02:09:00 EST
yumex-3.0.14-1.fc20 works
Comment 41 Max Fomin 2014-02-26 02:17:31 EST
(In reply to Fedora Update System from comment #38)
> yumex-3.0.14-1.fc20 has been submitted as an update for Fedora 20.
> https://admin.fedoraproject.org/updates/yumex-3.0.14-1.fc20
The bug is fixed. Thanks.
Comment 42 D. Charles Pyle 2014-02-26 05:51:26 EST
Created attachment 867918 [details]
Screenshot of Yumex in action with blank dialog at the end, while checking for updates after an update.

While it did not blank out the dialog listing the updates that would be installed, which would indicate that at least that part of the bug has been fixed, I still see it blank out at the end while checking for updates after an update has been done. I have attached a screen shot of Yumex as it ran a search for any further updates after updating.  Probably the same solution for the initial dialog likely will fix this issue completely.
Comment 43 Knut Torgersen 2014-02-26 09:54:19 EST
Yep, works - thanks!
Comment 44 Wolfgang Ulbrich 2014-02-26 10:07:36 EST
Thanks guys, yumex is back in race for the best package-manager for traditional desktops ;)
Comment 45 KitchM 2014-02-26 10:26:02 EST
When will it be available for update in Fedora 20?
Comment 46 Tim Lauridsen 2014-02-26 13:40:41 EST
(In reply to KitchM from comment #45)
> When will it be available for update in Fedora 20?

Soon, update is submitted and waiting to be pushed to the repositories
Comment 47 KitchM 2014-02-26 13:46:58 EST
Thanks.  I look forward to this fix.
Comment 48 Fedora Update System 2014-02-26 23:13:06 EST
yumex-3.0.14-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 49 KitchM 2014-02-27 11:37:23 EST
Just got the upgrade.  Will be watching it to see if the problem returns or is solved.

Thanks.
Comment 50 Fedora Update System 2014-03-08 23:35:07 EST
yumex-3.0.14-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.