Bug 1023882 - PID changed when rhc deploy the app without hot_deploy option but with hot_deploy marker
PID changed when rhc deploy the app without hot_deploy option but with hot_d...
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jhon Honce
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-28 04:27 EDT by Yan Du
Modified: 2015-05-14 19:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-28 09:19:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yan Du 2013-10-28 04:27:34 EDT
Description of problem:

create an app and disable the auto-deploy, add hot_deploy marker and rhc deploy the app, the hot_deploy marker doesn't work when manually deploy the app, check the PID after deploy, the PID has changed




Version-Release number of selected component (if applicable):
INT(devenv_3948)



How reproducible:
Always



Steps to Reproduce:
1. create an app and disable auto_deploy
2. touch .openshift/marker/hot_deploy and make some change in index
3. git push the change
4. deploy the app by rhc deploy $commitID -a $app
5. check the PID and check the change in website



Actual results:
app restarted and the PID changed during rhc deploy, even added hot_deploy marker in app.

root@openshift-ubuntu:~/test/php1# rhc deploy ad1190c -a php1
Deployment of git ref 'ad1190c' in progress for application php1 ...
Stopping PHP cartridge
[Mon Oct 28 03:35:14 2013] [warn] PassEnv variable SHELL was undefined
[Mon Oct 28 03:35:14 2013] [warn] PassEnv variable USER was undefined
[Mon Oct 28 03:35:14 2013] [warn] PassEnv variable LOGNAME was undefined
Waiting for stop to finish
Building git ref 'ad1190c', commit ad1190c
Building PHP cartridge
Preparing build for deployment
Deployment id is 3f9a4176
Activating deployment
Starting PHP cartridge
Success



Expected results:
the PID should keep the same ID


Additional info:

hot deploy marker works when auto deploy the app, and the PID keep the same.

root@openshift-ubuntu:~/test/php1# git add .; git commit -amp; git push
[master 9f1f9ba] p
 Committer: root <root@openshift-ubuntu.(none)>
 1 file changed, 1 insertion(+), 1 deletion(-)
 create mode 100644 .openshift/markers/hot_deploy
Counting objects: 11, done.
Compressing objects: 100% (6/6), done.
Writing objects: 100% (6/6), 521 bytes, done.
Total 6 (delta 3), reused 0 (delta 0)
remote: Not stopping cartridge php because hot deploy is enabled
remote: Building git ref 'master', commit 9f1f9ba
remote: Building PHP cartridge
remote: Preparing build for deployment
remote: Deployment id is 4775c73e
remote: Activating deployment
remote: Not starting cartridge php because hot deploy is enabled
remote: Result: success
remote: Activation status: success
remote: Deployment completed with status: success
To ssh://526e12c76cec0ee8da0000b8@php1-aaa.int.rhcloud.com/~/git/php1.git/
   186fa30..9f1f9ba  master -> master
Comment 1 Andy Goldstein 2013-10-28 09:19:05 EDT
This is by design - if you use "rhc deploy" you must specify --hot-deploy if you want to hot deploy.

Note You need to log in before you can comment on or make changes to this bug.