Bug 1023903 - ValueError: cannot initialize a disk that has partitions
ValueError: cannot initialize a disk that has partitions
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:f6fd2fbefd38ce9799acaa1b0d4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-28 05:50 EDT by Fujisan
Modified: 2014-03-05 09:38 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-05 09:38:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (930.22 KB, text/plain)
2013-10-28 05:50 EDT, Fujisan
no flags Details
File: anaconda.log (170.51 KB, text/plain)
2013-10-28 05:50 EDT, Fujisan
no flags Details
File: environ (441 bytes, text/plain)
2013-10-28 05:51 EDT, Fujisan
no flags Details
File: lsblk_output (2.09 KB, text/plain)
2013-10-28 05:51 EDT, Fujisan
no flags Details
File: nmcli_dev_list (3.50 KB, text/plain)
2013-10-28 05:51 EDT, Fujisan
no flags Details
File: os_info (179 bytes, text/plain)
2013-10-28 05:51 EDT, Fujisan
no flags Details
File: program.log (42.02 KB, text/plain)
2013-10-28 05:51 EDT, Fujisan
no flags Details
File: storage.log (264.31 KB, text/plain)
2013-10-28 05:51 EDT, Fujisan
no flags Details
File: syslog (128.11 KB, text/plain)
2013-10-28 05:51 EDT, Fujisan
no flags Details
File: ifcfg.log (573 bytes, text/plain)
2013-10-28 05:51 EDT, Fujisan
no flags Details
File: packaging.log (175.62 KB, text/plain)
2013-10-28 05:51 EDT, Fujisan
no flags Details

  None (edit)
Description Fujisan 2013-10-28 05:50:45 EDT
Version-Release number of selected component:
anaconda-19.30.13-1

The following was filed automatically by anaconda:
anaconda 19.30.13-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 810, in initializeDisk
    raise ValueError("cannot initialize a disk that has partitions")
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2041, in _destroy_device
    self.__storage.initializeDisk(device.disk)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2146, in on_remove_clicked
    self._destroy_device(dev)
ValueError: cannot initialize a disk that has partitions

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19
Comment 1 Fujisan 2013-10-28 05:50:53 EDT
Created attachment 816747 [details]
File: anaconda-tb
Comment 2 Fujisan 2013-10-28 05:50:57 EDT
Created attachment 816748 [details]
File: anaconda.log
Comment 3 Fujisan 2013-10-28 05:51:00 EDT
Created attachment 816749 [details]
File: environ
Comment 4 Fujisan 2013-10-28 05:51:04 EDT
Created attachment 816750 [details]
File: lsblk_output
Comment 5 Fujisan 2013-10-28 05:51:07 EDT
Created attachment 816751 [details]
File: nmcli_dev_list
Comment 6 Fujisan 2013-10-28 05:51:11 EDT
Created attachment 816752 [details]
File: os_info
Comment 7 Fujisan 2013-10-28 05:51:15 EDT
Created attachment 816753 [details]
File: program.log
Comment 8 Fujisan 2013-10-28 05:51:19 EDT
Created attachment 816754 [details]
File: storage.log
Comment 9 Fujisan 2013-10-28 05:51:23 EDT
Created attachment 816755 [details]
File: syslog
Comment 10 Fujisan 2013-10-28 05:51:26 EDT
Created attachment 816756 [details]
File: ifcfg.log
Comment 11 Fujisan 2013-10-28 05:51:30 EDT
Created attachment 816757 [details]
File: packaging.log
Comment 12 David Shea 2014-03-04 11:54:17 EST
Does this problem still occur on F20 or rawhide?
Comment 13 Fujisan 2014-03-05 03:17:35 EST
No, haven't crossed the problem on F20.
Comment 14 David Shea 2014-03-05 09:38:34 EST
Good to hear. We've made a lot of fixes and have changes to storage handling since F19. Sorry we missed this report, but I'm glad to know that it's been fixed.

Note You need to log in before you can comment on or make changes to this bug.