This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1023957 - Save the value of "Logrotate Max Log Size" into file "/etc/logrotate.d/ovirt-node" failed
Save the value of "Logrotate Max Log Size" into file "/etc/logrotate.d/ovirt-...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
: ZStream
Depends On: 1023452
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-28 08:49 EDT by Idith Tal-Kohen
Modified: 2013-11-27 19:12 EST (History)
16 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-17.el6_4.11
Doc Type: Bug Fix
Doc Text:
Previously the ovirt-node configuration file for logrotate had an invalid syntax which prevented Augeas from editing it. The syntax of the file has been fixed, and some code has been migrated to the new codebase, so Augeas can now edit and save the file.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-20 11:47:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 16223 None None None Never

  None (edit)
Description Idith Tal-Kohen 2013-10-28 08:49:00 EDT
This bug has been copied from bug #1023452 and has been proposed
to be backported to 6.4 z-stream (EUS).
Comment 6 haiyang,dong 2013-10-31 02:20:06 EDT
Test version:
RHEV-H 6.5 for RHEV 3.2 (6.5-20131029.0.3.2)
ovirt-node-2.5.0-17.el6_4.11

Enter into Logging page, then set the value of "Logrotate Max Log Size" as "2048",
check that the file "/etc/logrotate.d/ovirt-node"
[root@dhcp-10-149 admin]# cat /etc/logrotate.d/ovirt-node 
/var/log/ovirt*.log {
    rotate 3
    compress
    missingok
    size 2048
    create
}

the size was what we set value "2048", so the bug is fixed, change bug status to VERIFIED.
Comment 8 errata-xmlrpc 2013-11-20 11:47:26 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1528.html

Note You need to log in before you can comment on or make changes to this bug.