Bug 1023962 - ovirt hosted engine setup fails if storage is GlusterFS. Wrong storage domain path.
ovirt hosted engine setup fails if storage is GlusterFS. Wrong storage domain...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup (Show other bugs)
3.3.0
Unspecified Unspecified
high Severity urgent
: ---
: 3.3.0
Assigned To: Sandro Bonazzola
Leonid Natapov
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-28 09:00 EDT by Leonid Natapov
Modified: 2014-01-21 11:54 EST (History)
7 users (show)

See Also:
Fixed In Version: ovirt-hosted-engine-setup-1.0.0-0.7.beta2.el6ev
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:54:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20617 None None None Never
oVirt gerrit 20650 None None None Never
Red Hat Product Errata RHBA-2014:0083 normal SHIPPED_LIVE new package: ovirt-hosted-engine-setup 2014-01-21 16:42:22 EST

  None (edit)
Description Leonid Natapov 2013-10-28 09:00:55 EDT
Description of problem:
ovirt hosted engine setup fails if storage is a GlusterFS.
When using GlusterFS,the path to storage domain is differs from the path to storage domain when working with NFS. Setup doesn't take that into consideration and looks for storage domain in a not existing path. 



2013-10-28 13:36:51 DEBUG otopi.context context._executeMethod:137 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/otopi/context.py", line 127, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/ovirt-hosted-engine-setup/sanlock/lockspace.py", line 108, in _misc
    metadatadir = self._get_metadata_path()
  File "/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/ovirt-hosted-engine-setup/sanlock/lockspace.py", line 69, in _get_metadata_path
    root=ohostedcons.FileLocations.SD_MOUNT_PARENT_DIR,
RuntimeError: Path to storage domain dd71883f-e0d2-4eb3-b655-9e13e05b48ef not found in /rhev/data-center/mnt
2013-10-28 13:36:51 ERROR otopi.context context._executeMethod:146 Failed to execute stage 'Misc configuration': Path to storage domain dd71883f-e0d2-4eb3-b655-9e13e05b48ef not found in /rhev/data-center/mnt


Instructions for QA:
test that you can setup hosted engine using GlusterFS as storage.
Comment 1 Sandro Bonazzola 2013-10-29 07:58:25 EDT
merged on upstream master and 1.0 branch
Comment 3 Leonid Natapov 2013-11-03 05:33:31 EST
fixed.
Comment 4 Charlie 2013-11-27 20:20:24 EST
This bug is currently attached to errata RHBA-2013:15257. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 5 Sandro Bonazzola 2013-12-05 06:04:12 EST
hosted engine is a new package, does not need errata for specific bugs during its development.
Comment 6 errata-xmlrpc 2014-01-21 11:54:42 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0083.html

Note You need to log in before you can comment on or make changes to this bug.