Bug 1023966 - hosted-engine fails if libvirtd is down
hosted-engine fails if libvirtd is down
Status: CLOSED DUPLICATE of bug 1025350
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup (Show other bugs)
3.3.0
Unspecified Unspecified
high Severity high
: ---
: 3.3.0
Assigned To: Sandro Bonazzola
Leonid Natapov
integration
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-28 09:07 EDT by Yedidyah Bar David
Modified: 2013-11-10 06:55 EST (History)
4 users (show)

See Also:
Fixed In Version: ovirt-hosted-engine-setup-1.0.0-0.8.beta3.el6ev
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-08 03:54:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yedidyah Bar David 2013-10-28 09:07:57 EDT
Description of problem:

hosted-engine fails if libvirtd is down

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. service libvirtd stop
2. hosted-engine --deploy

Actual results:

[ ERROR ] Failed to execute stage 'Environment customization': Failed to connect socket to '/var/run/libvirt/libvirt-sock': No such file or directory

Expected results:

hosted-engine should start libvirtd if it's down and continue.
It should also configure it to start on reboot.

Additional info:
Comment 1 Sandro Bonazzola 2013-10-28 09:43:40 EDT
(In reply to Yedidyah Bar David from comment #0)
> [ ERROR ] Failed to execute stage 'Environment customization': Failed to
> connect socket to '/var/run/libvirt/libvirt-sock': No such file or directory

Can you attach full logs?
On upstream starting vdsmd also start supervdsmd and libvirtd and AFAIK it worked like that at least a few weeks ago.
Comment 2 Sandro Bonazzola 2013-11-08 03:54:33 EST
I'm not able to reproduce this with 
ovirt-hosted-engine-setup-1.0.0-0.8.beta3.el6ev.
I think that libvirtd missing was due to vdsm changes, so I'm marking this as duplicate.

*** This bug has been marked as a duplicate of bug 1025350 ***

Note You need to log in before you can comment on or make changes to this bug.