Bug 102401 - Symlink to libcrypt.so.2 not created
Symlink to libcrypt.so.2 not created
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: openssl096b (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Tomas Mraz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-14 15:03 EDT by Rick Johnson
Modified: 2007-04-18 12:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-09 04:06:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rick Johnson 2003-08-14 15:03:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b)
Gecko/20030731 Mozilla Firebird/0.6.1

Description of problem:
The symbolic link pointing to /lib/libcrypto.so.0.9.6b named /lib/libcrypto.so.2
is missing.

Older packages which require this compatability file are broken when this errata
release is installed from scratch as the symbolic link is not created.

Version-Release number of selected component (if applicable):
openssl096b-0.9.6b-6

How reproducible:
Always

Steps to Reproduce:
1. Install openssl096b-0.9.6b-6
2. Install a package which requires openssl096b (for libcrypto.so.2) such as
Yahoo! Messenger RPM for Red Hat 8.0.
3. Attempt to run application (i.e. ymessenger) which requires libcrypto.so.2
    

Actual Results:  Program fails to execute since file/symlink is missing. ldd
shows that linked library is missing.

Expected Results:  Program should run correctly since the package dependancy of
openssl096b was installed.

Additional info:

When querying the rpmdb-redhat database with --redhatprovides,
/lib/libcrypto.so.2 is listed as owned by openssl096b.

Manually creating the symbolic link fixes the problem.
Comment 1 Curtis Doty 2004-03-16 20:38:41 EST
The proper way to create those links is to use ldconfig. Which 
openssl096b appears to attempt...

$ rpm -q --scripts openssl096b-0.9.6b-14
postinstall program: /sbin/ldconfig
postuninstall program: /sbin/ldconfig

But alas, this never happens for some reason. And one can verify by 
attempting to relink as non-root user...

$ /sbin/ldconfig -N
/sbin/ldconfig: Can't link /lib/libssl.so.2 to libssl.so.0.9.6b
/sbin/ldconfig: Can't link /lib/libcrypto.so.2 to libcrypto.so.0.9.6b

The work-around, of course, is to run ldconfig as root...

In my case, openssl096b was brought in as a dependency. Maybe the 
script was played out of order?

Fetching rpm headers...
########################################

Name                                    Version        Rel     
----------------------------------------------------------
compat-gcc-c++                          7.3            
2.96.118            i386  
openssl096b                             0.9.6b         
14                  i386  


Testing package set / solving RPM inter-dependencies...
########################################
compat-gcc-c++-7.3-2.96.118 ########################## 
Done.                   
openssl096b-0.9.6b-14.i386. ########################## 
Done.                   
compat-gcc-7.3-2.96.118.i38 ########################## 
Done.                   
compat-libstdc++-7.3-2.96.1 ########################## 
Done.                   
compat-libstdc++-devel-7.3- ########################## 
Done.                   
Preparing              ########################################### 
[100%]

Installing...
   1:compat-libstdc++       
########################################### [100%]
   2:compat-libstdc++-devel 
########################################### [100%]
   3:compat-gcc             
########################################### [100%]
   4:compat-gcc-c++         
########################################### [100%]
   5:openssl096b            
########################################### [100%]
The following packages were added to your selection to satisfy 
dependencies:

Name                                    Version        Release
--------------------------------------------------------------
compat-gcc                              7.3            
2.96.118            
compat-libstdc++                        7.3            
2.96.118            
compat-libstdc++-devel                  7.3            
2.96.118            
Comment 2 Tomas Mraz 2005-02-09 04:06:22 EST
This isn't a bug in the package.
Comment 3 Curtis Doty 2005-02-09 15:06:51 EST
Tomas, where is the bug then?
Comment 4 Tomas Mraz 2005-02-10 03:15:22 EST
Probably in rpm.

Note You need to log in before you can comment on or make changes to this bug.