Bug 1024022 - creating node.js 0.10 application with --from-code starts two instances of the application running supervisor
creating node.js 0.10 application with --from-code starts two instances of th...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jhon Honce
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-28 11:15 EDT by Corey Daley
Modified: 2015-05-14 19:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-23 22:27:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Daley 2013-10-28 11:15:35 EDT
Description of problem:
Creating an application with --from-code starts two instances of the application with supervisor, resulting in the error logs filling with bind errors since the second application can not bind to port 8080

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Create node.js 0.10 application from command line using --from-code
2. use rhc tail $appname to watch errors come across
3.ssh into application and you can see two supervisor applications running
4. restart the application and it will be fixed

Actual results:
Two processes with supervisor running your node application are started, creating errors in the log about binding to port 8080

Expected results:
The application should run only once.

Additional info:
rhc app create ghost nodejs-0.10 --env NODE_ENV=production --from-code https://github.com/developercorey/openshift-ghost-quickstart.git

rhc app create ghost nodejs-0.10 --from-code https://github.com/developercorey/openshift-nodejs-websocket-example.git
Comment 1 openshift-github-bot 2013-10-28 21:15:25 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/1ebbb1f326bfae61d376ebe483e9b6a2a836734c
Bug 1024022 - cartridge allows two starts of supervisor

* Follow other cartridges and starting a started cartridge is a NO-OP
Comment 2 Yan Du 2013-10-29 02:39:02 EDT
test on devenv_3959

steps:
1. rhc app create ghost1 nodejs-0.10 --env NODE_ENV=production --from-code https://github.com/developercorey/openshift-ghost-quickstart.git
2. rhc tail $app to check the log
2. ssh into app and check the supervisor process

only one supervisor process running for the app.
[ghost1-dyy.dev.rhcloud.com 526f56fb9778af895900003f]\> ps -ef
UID        PID  PPID  C STIME TTY          TIME CMD
1002     19409     1  3 02:35 ?        00:00:06 node /opt/rh/nodejs010/root/usr/bin/supervisor -e node|js|coffee -p 1000 -- index.js
1002     19431 19409  0 02:35 ?        00:00:01 node index.js
1002     20563 20447  0 02:38 ?        00:00:00 sshd: 526f56fb9778af895900003f@pts/2
1002     20594 20563  3 02:38 pts/2    00:00:00 /bin/bash --init-file /usr/bin/rhcsh -i
1002     21060 20594  0 02:38 pts/2    00:00:00 ps -ef


move to verified.

Note You need to log in before you can comment on or make changes to this bug.