Bug 1024025 - [RFE] katello-disconnected: configure should read oauth creds from server.conf and/or be used to populate
[RFE] katello-disconnected: configure should read oauth creds from server.con...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Packaging (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Mike McCune
Katello QA List
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-28 11:31 EDT by Corey Welton
Modified: 2016-02-08 13:34 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-08 13:34:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2013-10-28 11:31:24 EDT
Description of problem:
When setting up katello disconnected, the steps are:

1. create oauth secret
2. manually replace oauth credentials in pulp server.conf
3. run 'katello-disconnected configure --oauth-key=<key> --oauth-secret=<secret>" -- basically respecifying the stuff you've manually entered into the pulp server.conf

This is error-prone and somewhat cumbersome. Is there any reason we can't, in step 3, simply read from server.conf the stuff we just added in step 2, as default values for 'katello-disconnected configure'?  We could keep the --oauth-secret and --oauth-key flags as optional, in case a user wants to, for whatever reason, specify something else. 

Alternately, we could also populate server.conf at 'katello-disconnected configure' runtime - but I don't know what implications of that might be.  Just a consideration.
Comment 4 Bryan Kearney 2016-02-08 13:34:09 EST
The katello-disconnected server synchronization and export functions are being moved into the Satellite server itself. With 6.2, the katello-disconnected command will no longer be delivered and instead will be replaced with a new export and import functions delivered via the UI and hammer CLI. This bug is being closed as "WONTFIX" since it relates only to the existing katello-disconnected tooling. Please check the Satellite docs with the release of Satellite 6.2 on how to use the new content export and import features.

Note You need to log in before you can comment on or make changes to this bug.