Bug 1024035 - Support junction resolution in RHEL 6 rpc.mountd
Support junction resolution in RHEL 6 rpc.mountd
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nfs-utils (Show other bugs)
6.6
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Steve Dickson
Yin.JianHong
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-28 12:12 EDT by Chuck Lever
Modified: 2014-10-14 00:32 EDT (History)
3 users (show)

See Also:
Fixed In Version: nfs-utils-1.2.3-49.el6
Doc Type: Bug Fix
Doc Text:
With FedFS support, RHEL server can now manage NFS V4 namespaces via referrals or junctions.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 00:32:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1407 normal SHIPPED_LIVE nfs-utils bug fix and enhancement update 2014-10-13 20:54:56 EDT

  None (edit)
Description Chuck Lever 2013-10-28 12:12:32 EDT
Description of problem:

At the NFS bake-a-thon last month we discussed the possibility of adding junction resolution support to RHEL 6 nfs-utils.  Here are the upstream commits I believe are necessary to enable junction resolution support in mountd.

Please see upstream commits 11d4f1d2, dbc0b5e8, 9fae1474, 8b15252e, 88f0f36a, fb62e4dc, a8dcaa28, d6979553, ab74900f, and 73840ef6.
Comment 2 RHEL Product and Program Management 2013-10-31 13:08:39 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 8 errata-xmlrpc 2014-10-14 00:32:07 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1407.html

Note You need to log in before you can comment on or make changes to this bug.