Bug 1024048 - [xfsprogs] Move xfs_types.h from xfsprogs-qa-devel to xfsprogs-devel
[xfsprogs] Move xfs_types.h from xfsprogs-qa-devel to xfsprogs-devel
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xfsprogs (Show other bugs)
7.0
All Linux
high Severity high
: rc
: ---
Assigned To: Eric Sandeen
Boris Ranto
:
: 1058014 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-28 12:44 EDT by Boris Ranto
Modified: 2014-06-18 00:55 EDT (History)
5 users (show)

See Also:
Fixed In Version: xfsprogs-3.2.0-0.2.alpha1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 08:29:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Boris Ranto 2013-10-28 12:44:30 EDT
Description of problem:
The new xfsprogs 3.2.0-alpha1 includes <xfs/xfs_types.h> in <xfs/xfs.h>. Please, move the file from xfsprogs-qa-devel to xfsprogs-devel so that the compilation of utilities using <xfs/xfs.h> does not fail.

Version-Release number of selected component (if applicable):
xfsprogs-3.2.0-0.1.alpha1.el7

How reproducible:
Always

Steps to Reproduce:
1. Compile a C program with #include <xfs/xfs.h>
2. 
3.

Actual results:
The compilation fails with /usr/include/xfs/xfs.h:37:27: fatal error: xfs/xfs_types.h: No such file or directory.

Expected results:
The compilation succeeds.

Additional info:
Comment 1 Dave Chinner 2013-10-30 20:01:36 EDT
Eric,

This seems like a problem with the rpm build? The include/Makefile defines xfs_types.h as a header file that should be installed via the install-dev makefile rule. Indeed, the install-qa makefile rule does *not* install xfs_types.h, so perhaps the rpm build scripts are getting the install directives wrong?

FWIW, the Debian xfslibs-dev package build out of the upstream repository for 3.2.0-alpha installs /usr/include/xfs/xfs_types.h correctly, which further points to an rpm build problem....

-Dave.
Comment 2 Eric Sandeen 2013-11-04 13:36:29 EST
Dave,

For rpm spec files, there is no mapping from install-$FOO targets to subpackage AFAIK.  We just have to run every install-$FOO we want, and sort the results into subpackages in %file lists.

I'm not sure if there are any better tools now, but from the old RPM book, "At present, the best way to create the file list is to read the makefile to see what files it installs, verify this against the files installed on the build system, and create the list."  Not terribly robust.

In any case, yeah, it's a packaging problem, not a Makefile or code problem.
Comment 3 Eric Sandeen 2013-11-04 14:30:30 EST
I did double check that other than this xfs_types.h problem, each subpackage does now have the proper set of files installed by each install-$FOO target.

-Eric
Comment 7 Boris Ranto 2014-01-27 07:32:36 EST
*** Bug 1058014 has been marked as a duplicate of this bug. ***
Comment 8 Ludek Smid 2014-06-13 08:29:43 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.