Bug 1024117 - HR process build failing
HR process build failing
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
All Linux
high Severity high
: ER5
: 6.0.0
Assigned To: manstis
Tomas David
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-28 17:49 EDT by Roger Martínez
Modified: 2014-08-06 16:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:19:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
HR Process definition (16.51 KB, application/zip)
2013-10-28 17:49 EDT, Roger Martínez
no flags Details

  None (edit)
Description Roger Martínez 2013-10-28 17:49:52 EDT
Created attachment 816932 [details]
HR Process definition

Description of problem: Build&deploy operation for HR process fails and the user feedback message diplays "Build&deploy successfull" (incorrect).


Version-Release number of selected component (if applicable): 6.1.0-SNAPSHOT (build 28oct 2013)


How reproducible: 



Steps to Reproduce:
1. Select jbpm-playground repo and HR process in project explorer
2. Click on Build&Deploy 
3. An exception is thrown (see log) but user message says it's correct.

Actual results:


Expected results:


Additional info:

The exception is:

22:45:14,760 ERROR [org.guvnor.common.services.builder.ResourceChangeIncrementalBuilder] (pool-13-thread-2) String index out of range: -3: org.guvnor.common.services.shared.exceptions.GenericPortableException: String index out of range: -3
        at org.guvnor.common.services.backend.exceptions.ExceptionUtilities.handleException(ExceptionUtilities.java:24) [guvnor-services-api-6.1.0-SNAPSHOT.jar:6.1.0-SNAPSHOT]
        at org.guvnor.common.services.builder.BuildServiceImpl.updatePackageResource(BuildServiceImpl.java:190) [guvnor-project-builder-6.1.0-SNAPSHOT.jar:6.1.0-SNAPSHOT]
        at org.guvnor.common.services.builder.BuildServiceImpl$Proxy$_$$_WeldClientProxy.updatePackageResource(BuildServiceImpl$Proxy$_$$_WeldClientProxy.java) [guvnor-project-builder-6.1.0-SNAPSHOT.jar:6.1.0-SNAPSHOT]
        at org.guvnor.common.services.builder.ResourceChangeIncrementalBuilder$4.run(ResourceChangeIncrementalBuilder.java:237) [guvnor-project-builder-6.1.0-SNAPSHOT.jar:6.1.0-SNAPSHOT]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_40]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_40]
        at java.lang.Thread.run(Thread.java:724) [rt.jar:1.7.0_40]
Comment 2 manstis 2013-10-29 18:57:23 EDT
A number of questions.

(1) What steps are you actually completing? You state you clicked "Build & Deploy" however the log shows an incremental compilation that happens when you save a file; not "Build & Deploy" a project. What did you actually do?

(2) I tried to open the "hiring" process with jBPM Designer however it complained the process file was invalid. I also noticed a number for additional log entries for "non-viable character '/'" (or similar). Could relate to an invalid process file?

Thanks,

Mike
Comment 3 manstis 2013-10-30 05:40:45 EDT
I can replicate the error with kie-wb:-

09:36:50,523 INFO  [org.guvnor.common.services.builder.ResourceChangeIncrementalBuilder] (pool-29-thread-2) Incremental build request being processed: default://master@jbpm/HR/project.imports (updated).
09:36:50,659 ERROR [org.guvnor.common.services.builder.ResourceChangeIncrementalBuilder] (pool-29-thread-2) String index out of range: -3: org.guvnor.common.services.shared.exceptions.GenericPortableException: String index out of range: -3
	at org.guvnor.common.services.backend.exceptions.ExceptionUtilities.handleException(ExceptionUtilities.java:24) [guvnor-services-api-6.1.0-SNAPSHOT.jar:6.1.0-SNAPSHOT]
	at org.guvnor.common.services.builder.BuildServiceImpl.updatePackageResource(BuildServiceImpl.java:192) [guvnor-project-builder-6.1.0-SNAPSHOT.jar:6.1.0-SNAPSHOT]
	at org.guvnor.common.services.builder.BuildServiceImpl$Proxy$_$$_WeldClientProxy.updatePackageResource(BuildServiceImpl$Proxy$_$$_WeldClientProxy.java) [guvnor-project-builder-6.1.0-SNAPSHOT.jar:6.1.0-SNAPSHOT]
	at org.guvnor.common.services.builder.ResourceChangeIncrementalBuilder$4.run(ResourceChangeIncrementalBuilder.java:242) [guvnor-project-builder-6.1.0-SNAPSHOT.jar:6.1.0-SNAPSHOT]
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895) [rt.jar:1.6.0_45]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918) [rt.jar:1.6.0_45]
	at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_45]

Looks like project.imports is causing the problem... investigating.
Comment 4 Roger Martínez 2013-10-30 06:09:51 EDT
Hi Mike,

About (1): I just clicked "Build&Deploy" and then a popup appears. This popup allows to save the project, and I saved it... so it's probably that the problem can be on save operation rather than build.


About (2): I don't remember right now if the process open without error, but I'm quite sure that it opened as well. Anyway, the additional log entries (non-viable character '/') always appear... it's not a new issue. So I might not be the problem... 

See you on IRC ;)
Comment 5 manstis 2013-10-30 07:18:23 EDT
This was a problem within KieBuilderImpl for resources that were not inside a package (i.e. "<project-root>/project.imports" in this case). Mario made KieBuilderImpl more robust and we filter non-package resources from incremental builds. The project was successfully building, so the message remained correct; but incremental build failed. Anyway.. fixed now.
Comment 7 Tomas David 2013-12-13 10:40:56 EST
Verified on BPMS 6.0.0.ER5.

Note You need to log in before you can comment on or make changes to this bug.