Bug 1024165 - Unable to set keep_deployments if an app has been deployed without code change
Unable to set keep_deployments if an app has been deployed without code change
Status: CLOSED DUPLICATE of bug 1023304
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Abhishek Gupta
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-28 23:28 EDT by Jianwei Hou
Modified: 2015-05-14 20:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-29 13:53:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Broker development.log (13.50 KB, text/x-log)
2013-10-28 23:28 EDT, Jianwei Hou
no flags Details

  None (edit)
Description Jianwei Hou 2013-10-28 23:28:14 EDT
Created attachment 816959 [details]
Broker development.log

Description of problem:
Deploy an application without pushing any code change, the app is deployed with an id. Then set the keep_deployments of the app, an error will occur "Unable to complete the requested operation due to: undefined method `each' for nil:NilClass.\nReference ID: 6c2c177669d583fb7b9db4433e942cf0"

Version-Release number of selected component (if applicable):
On devenv_3958

How reproducible:
Always

Steps to Reproduce:
1. Create a diy application
2. Don't do anything, and deploy the app directly
3. Set the keep_deployments of the app via RESTAPI
curl -s -k -H 'Content-Type: Application/json' --user jhou@redhat.com:x https://ec2-50-19-142-185.compute-1.amazonaws.com/broker/rest/domain/jhou/application/d1 -X PUT -d '{"keep_deployments": 5}'


Actual results:
After step 3:
{
    "api_version": 1.6,
    "data": null,
    "messages": [
        {
            "exit_code": 1,
            "field": null,
            "index": null,
            "severity": "error",
            "text": "Unable to complete the requested operation due to: undefined method `each' for nil:NilClass.\nReference ID: 6c2c177669d583fb7b9db4433e942cf0"
        }
    ],
    "status": "internal_server_error",
    "supported_api_versions": [
        1.0,
        1.1,
        1.2,
        1.3,
        1.4,
        1.5,
        1.6
    ],
    "type": null,
    "version": "1.6"
}


Expected results:
The application should be updated successfully.

Additional info:
Comment 1 Abhishek Gupta 2013-10-29 13:13:49 EDT
This should be fixed with --> https://github.com/openshift/origin-server/pull/4026
(Image: devenv_3961)
Comment 2 Lili Nader 2013-10-29 13:53:51 EDT

*** This bug has been marked as a duplicate of bug 1023304 ***

Note You need to log in before you can comment on or make changes to this bug.