Bug 102420 - 5.0.8-7.1 fails to build with --NET-SNMP-IN-SOURCE=true
5.0.8-7.1 fails to build with --NET-SNMP-IN-SOURCE=true
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: net-snmp (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-14 18:31 EDT by Kaj J. Niemi
Modified: 2015-03-04 20:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-15 10:20:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaj J. Niemi 2003-08-14 18:31:30 EDT
Description of problem:
Building of net-snmp 5.0.8-7.1 fails if --NET-SNMP-IN_SOURCE=true is defined (at
least) under perl-5.8.1-90.rc4.0 (off Rawhide)

Version-Release number of selected component (if applicable):
perl-5.8.1-90.rc4.0
net-snmp-5.0.8-7.1

How reproducible:
Always

Steps to Reproduce:
1. Sync to latest of everything off rawhide
2. rpmbuild -ba net-snmp.spec
3. Wait until it starts building the perl modules
    
Actual results:
....
Writing Makefile for NetSNMP::agent::default_store
Writing Makefile for NetSNMP::agent
Checking if your kit is complete...
Looks good
ERROR from evaluation of
/usr/src/redhat/BUILD/net-snmp-5.0.8/perl/SNMP/Makefile.PL: Modification of a
read-only value attempted at /usr/lib/perl5/5.8.1/Carp/Heavy.pm line 52.
error: Bad exit status from /var/tmp/rpm-tmp.66041 (%build)

The failing sub-component is actually the one after agent (./perl/SNMP)

Expected results:
Should build cleanly

Additional info:
Removing --NET-SNMP-IN-SOURCE=true enables a successful build.
Comment 1 Kaj J. Niemi 2003-08-14 18:54:52 EDT
Looks like it should be "-NET-SNMP-IN-SOURCE=true" instead of
"--NET-SNMP-IN-SOURCE" (./perl/SNMP/README)

Removing the extra dash on that particular line in the .spec file makes
everything work again.

WORKSFORME
Comment 2 Kaj J. Niemi 2003-08-14 18:56:30 EDT
Oops, hit enter in the wrong place.

That should be "-NET-SNMP-IN-SOURCE=true" instead of
"--NET-SNMP-IN-SOURCE=true" (according to ./perl/SNMP/README)

Thanks... :)
Comment 3 Phil Knirsch 2003-08-15 10:20:49 EDT
OK, fixed in net-snmp-5.0.8-8 and later. :-)

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.