Bug 1024217 - Error while updating: libsepol.print_missing_requirements: icecream's global requirements were not met: bool init_systemd (No such file or directory)
Error while updating: libsepol.print_missing_requirements: icecream's global ...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: icecream (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Schmidt
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-29 03:11 EDT by Petr Pisar
Modified: 2015-01-05 03:48 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-05 03:48:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2013-10-29 03:11:13 EDT
While upgrading or reinstalling selinux-policy (selinux-policy-3.12.1-74.11.fc19 or 3.12.1-74.10.fc19) I get following error message:

Running transaction
  Instalování: selinux-policy-3.12.1-74.11.fc19.noarch                      1/1 
libsepol.print_missing_requirements: icecream's global requirements were not met: bool init_systemd (No such file or directory).
libsemanage.semanage_link_sandbox: Link packages failed (No such file or directory).
semodule:  Failed!

I guess something is wrong with policies for icecream package which I have installed.
Comment 1 Petr Pisar 2013-10-29 03:13:44 EDT
Maybe it's because icecream has never been built for F19. There is F18 build in F19 repositories. Next successful icecream build is for F20.
Comment 2 Peter H. Jones 2014-09-15 05:14:53 EDT
Got a similar message in an experimental live build:

"Preparing...                          ########################################
Updating / installing...
selinux-policy-3.13.1-81.fc21         ########################################
selinux-policy-devel-3.13.1-81.fc21   ########################################
selinux-policy-minimum-3.13.1-81.fc21 ########################################
libsepol.print_missing_requirements: apache's global requirements were not met: type/attribute automount_tmp_t (No such file or directory).
libsemanage.semanage_link_sandbox: Link packages failed (No such file or directory).
/usr/sbin/semodule:  Failed!
selinux-policy-mls-3.13.1-81.fc21     ########################################
selinux-policy-targeted-3.13.1-81.fc21########################################
Cleaning up / removing...
selinux-policy-targeted-3.13.1-79.fc21########################################
selinux-policy-mls-3.13.1-79.fc21     ########################################
selinux-policy-minimum-3.13.1-79.fc21 ########################################
selinux-policy-devel-3.13.1-79.fc21   ########################################
selinux-policy-3.13.1-79.fc21         ########################################
"

In other words, I was updating from selinux-policy-minimum-3.13.1-79.fc21 to selinux-policy-minimum-3.13.1-81.fc21 .
Comment 3 Daniel Walsh 2015-01-03 10:10:51 EST
Remove the icecream.pp file should clean this up.

semodule -r icecream

Since we never shipped icecream policy we really can not fix it.
Comment 4 Petr Pisar 2015-01-05 02:22:11 EST
I'm sorry, but the policy is delivered by the icecream package:

# rpm -qf /usr/share/selinux/*/icecream.pp 
icecream-1.0.1-11.20140822git.fc20.x86_64
icecream-1.0.1-11.20140822git.fc20.x86_64
icecream-1.0.1-11.20140822git.fc20.x86_64
Comment 5 Michal Schmidt 2015-01-05 03:25:52 EST
> icecream-1.0.1-11.20140822git.fc20.x86_64

Are you still seeing the error with this icecream version?
Comment 6 Petr Pisar 2015-01-05 03:48:27 EST
(In reply to Michal Schmidt from comment #5)
> > icecream-1.0.1-11.20140822git.fc20.x86_64
> 
> Are you still seeing the error with this icecream version?

Not anymore. Tested in F19 (icecream-1.0.1-11.20140822git.fc19.x86_64, selinux-policy-3.12.1-74.30.fc19.noarch), F20 (icecream-1.0.1-11.20140822git.fc20.x86_64,
selinux-policy-3.12.1-196.fc20.noarch) and F22 (icecream-1.0.1-11.20140822git.fc22.x86_64, selinux-policy-3.13.1-101.fc22.noarch).

Note You need to log in before you can comment on or make changes to this bug.