Bug 1024317 - matedialog does not work because of wrong path of resource files
matedialog does not work because of wrong path of resource files
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mate-dialogs (Show other bugs)
19
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-29 07:35 EDT by Jakob Hirsch
Modified: 2013-11-10 02:16 EST (History)
4 users (show)

See Also:
Fixed In Version: mate-dialogs-1.6.2-0.1.git59337c9.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-06 22:36:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakob Hirsch 2013-10-29 07:35:48 EDT
Description of problem:

After the update to mate-dialogs-1.6.1-1.fc19, the matedialog programm will not show a dialog, but will stop with this error message:

$ matedialog  --error

** (matedialog:31755): WARNING **: Could not load ui file /usr/share/mate-dialogs/matedialog.ui: Failed to open file '/usr/share/mate-dialogs/matedialog.ui': No such file or directory

(matedialog:31755): Gtk-CRITICAL **: IA__gtk_builder_get_object: assertion `GTK_IS_BUILDER (builder)' failed

(matedialog:31755): Gtk-CRITICAL **: IA__gtk_builder_get_object: assertion `GTK_IS_BUILDER (builder)' failed


This is obviously caused by inconsisten path information. The package installs matedialog.ui into /usr/share/matedialog/, but as you can see from the error message, matedialogs tries to load it from /usr/share/mate-dialogs/.

Version-Release number of selected component (if applicable):

mate-dialogs-1.6.1-1.fc19.x86_64

How reproducible:

alwasy

Steps to Reproduce:
1. Open a terminal window (e.g. mate-terminal)
2. start "matedialog  --error"

Actual results:

Error message in the console window.

Expected results:

A dialog window.

Additional info:

none.
Comment 1 Wolfgang Ulbrich 2013-10-29 08:12:24 EDT
Confirmed and send to upstream.
https://github.com/mate-desktop/mate-dialogs/issues/13
Comment 2 Fedora Update System 2013-10-29 10:09:16 EDT
mate-dialogs-1.6.2-0.1.git59337c9.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mate-dialogs-1.6.2-0.1.git59337c9.fc19
Comment 3 Fedora Update System 2013-10-29 10:09:26 EDT
mate-dialogs-1.6.2-0.1.git59337c9.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mate-dialogs-1.6.2-0.1.git59337c9.fc20
Comment 4 Fedora Update System 2013-10-29 10:09:36 EDT
mate-dialogs-1.6.2-0.1.git59337c9.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mate-dialogs-1.6.2-0.1.git59337c9.fc18
Comment 5 Fedora Update System 2013-10-29 14:06:31 EDT
Package mate-dialogs-1.6.2-0.1.git59337c9.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mate-dialogs-1.6.2-0.1.git59337c9.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20235/mate-dialogs-1.6.2-0.1.git59337c9.fc20
then log in and leave karma (feedback).
Comment 6 Jakob Hirsch 2013-10-30 08:01:08 EDT
I tried mate-dialogs-1.6.2-0.1.git59337c9.fc19.x86_64 (since I have F19 running) and it works indeed.
Comment 7 Fedora Update System 2013-11-06 22:36:42 EST
mate-dialogs-1.6.2-0.1.git59337c9.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-11-06 22:38:42 EST
mate-dialogs-1.6.2-0.1.git59337c9.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2013-11-10 02:16:30 EST
mate-dialogs-1.6.2-0.1.git59337c9.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.