Bug 1024328 - Exception when trying to create a Process-Form
Exception when trying to create a Process-Form
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Form Modeler (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium
: ER5
: 6.0.0
Assigned To: Neus Miras
Tomas Livora
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-29 08:14 EDT by Patrick Steiner
Modified: 2014-08-06 16:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build Name: 13464, Getting Started Guide-6-Beta-1 Build Date: 28-10-2013 13:46:10 Topic ID: 13469-547483 [Latest]
Last Closed: 2014-08-06 16:13:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
NoTaskSelected.png (28.88 KB, image/png)
2013-11-08 10:03 EST, Neus Miras
no flags Details
TaskSelected.png (33.18 KB, image/png)
2013-11-08 10:04 EST, Neus Miras
no flags Details

  None (edit)
Description Patrick Steiner 2013-10-29 08:14:34 EDT
Title: Exception when trying to create a Process-Form

Describe the issue:
I have created a new, simple process which should only display one process variable on the console. I have defined a process variable "employee" as "String".
When trying to create the "Process Form" I can only select "Edit Process Form" or "Generate all". When selecting "Edit Process Form" I do get an exception, as there is none to edit.

Generating "all" seems to be confusing. Is he generating all or only the once that are not present yet? What I I already have another, e.g. Task-Form in my process. Will this be overwritten?

Suggestions for improvement:
- Disable "Edit" if there is nothing to edit
- Have "Edit" create the missing form


Additional information:
Comment 2 Neus Miras 2013-11-08 10:02:46 EST
I think the best way to respond this issue is explain the current behaviour. When the user access the forms menu, has two situations:

- When no task is selectedAttached image:NoTaskSelected.png)
   * Edit Process Form. Allows access to the process initial form.  If it doen't  exist, a new empty form is created and the data binding had to be defined manually.
   * Generate all forms. Generates the process forms (for each user type task an the intial form ) with the data bindings automatically defined. And just in case the form doesn't exist, adds the related fields.

- When a task is selectedAttached (image:TaskSelected.png)
   * Edit Task Form.  Allows access to the task form.  If it doen't  exist, a new empty form is created and the data binding had to be defined manually.
   * Generate Task Form. Generate the task form with the data bindings automatically defined. In case that the form exists, the databinding are updated but the fields are no added to the existing form to avoid overwrite changes that the user could done manually.
Comment 3 Neus Miras 2013-11-08 10:03:27 EST
Created attachment 821674 [details]
NoTaskSelected.png
Comment 4 Neus Miras 2013-11-08 10:04:04 EST
Created attachment 821675 [details]
TaskSelected.png
Comment 5 Patrick Steiner 2013-11-12 11:02:59 EST
The described behaviour is not the one seen by the V6 Beta Version.

Will this be part of the next Beta drop?
Comment 6 Lukáš Petrovický 2013-11-13 02:53:02 EST
(In reply to Patrick Steiner from comment #5)
> Will this be part of the next Beta drop?

Yes. "MODIFIED" status means that the code will make it to the next build. (When that build gets to you, I don't know.)
Comment 7 Tomas Livora 2013-11-29 10:12:52 EST
Verified on BPMS 6.0.0.ER5

Note You need to log in before you can comment on or make changes to this bug.