Bug 1024376 - Provide option to choose between MySQL and MariaDB
Provide option to choose between MySQL and MariaDB
Status: CLOSED WONTFIX
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: Icehouse
Assigned To: RHOS Maint
Nir Magnezi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-29 10:33 EDT by Martin Magr
Modified: 2014-01-15 07:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-15 07:56:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Magr 2013-10-29 10:33:03 EDT
Packstack should provide option to choose between MariaDB and MySQL. MariaDB should be the default.
Comment 1 Martin Magr 2013-10-29 11:29:17 EDT
With this change we should probably patch puppet-mysql to use community-mysql* packages (currently it's using mariadb packages for Fedora) and start using (or create) puppet-mariadb module.
Comment 2 Martin Magr 2014-01-15 07:56:56 EST
Since there are fixes for MariaDB Fedora, this does not make sense any more.

Note You need to log in before you can comment on or make changes to this bug.