Bug 102441 - After an upgrade from RedHat 7.3 to RedHat 9 emacs scrolls differently.
After an upgrade from RedHat 7.3 to RedHat 9 emacs scrolls differently.
Status: CLOSED DUPLICATE of bug 90193
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-15 03:08 EDT by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-08-15 03:08:45 EDT
This is a very annoyning change in emacs which exists in RedHat 9
and not existed in RedHat 7.3.

in RedHat 9, when I mark some block by a mouse and then scroll 
text via pageup/pagedown the selection area extends to the current cursor position.
I need to type Alt-w to stop this.
This is even more annoying when by mistake pressing Ctl-w instead of Alt-w 
and the block gets deleted.

It was so much more convinient in RedHat 7.3, where 
there was to automatic change of selected area during scrolling,
and no Alt-w for every block copying was required to press.
Comment 1 Jens Petersen 2003-10-27 08:06:17 EST
Hmmm, I think this is transient-mark-mode, which is turned on
by default in new .emacs files.  Without it there is no visual
feedback when mark a block using keybindings.
Comment 2 Jens Petersen 2004-01-13 03:03:13 EST
Personally, I rather like transient-mark-mode, but since
setting it in the default .emacs files changes the default
behaviour of Emacs, I'll comment it out the setting for now
in emacs-21.3-8.
Comment 3 Jens Petersen 2004-01-14 02:58:10 EST
Btw you can easily change this behaviour in your .emacs file
by commenting out the line:

(setq transient-mark-mode t)

with a semi-colon.
Comment 4 Jens Petersen 2004-04-15 11:01:38 EDT

*** This bug has been marked as a duplicate of 90193 ***
Comment 5 Red Hat Bugzilla 2006-02-21 13:58:06 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.