Bug 1024438 - Section 2.1: Need to update order of yum-utils installation
Section 2.1: Need to update order of yum-utils installation
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs Install Guide (Show other bugs)
6.0.2
Unspecified Unspecified
low Severity low (vote)
: Unspecified
: --
Assigned To: Athene Chan
Dan Macpherson
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-29 12:28 EDT by Mike McCune
Modified: 2015-05-11 18:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-18 21:42:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2013-10-29 12:28:35 EDT
http://deathstar1.usersys.redhat.com:3000/builds/14370-Installation_Guide/#Installing_Red_Hat_Satellite

The docs state that yum-utils is a pre-req for Satellite 6 but you can't install it without being registered. 

It is confusing as a user because if they see:

"Oh, yum-utils is a pre-req, let me install it first"

it will fail because the system most likely isn't registered with subscription-manager like outlined in the following steps.  

We should order it such that:

1) Verify the availability of Satellite channels with the following command as the root user:

2) Subscribe to the pool using the following command:

 # subscription-manager subscribe --pool=[pool id]

3) Install yum-utils if not already installed:

 # yum install yum-utils

4) Disable all existing repositories:

 # yum-config-manager --disable "*"

....
Comment 1 RHEL Product and Program Management 2013-10-29 12:36:31 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 7 Dan Macpherson 2013-11-11 01:24:22 EST
Downgrading the severity of this bug. The instructions have been corrected, but minor styling issue exist.

Note You need to log in before you can comment on or make changes to this bug.