Bug 1024460 - subscription-manager refresh does not update redhat.repo
subscription-manager refresh does not update redhat.repo
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
John Sefler
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-29 13:10 EDT by Felix Dewaleyne
Modified: 2013-10-30 10:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-30 08:51:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felix Dewaleyne 2013-10-29 13:10:03 EDT
Description of problem:
subscription-manager refresh does not update redhat.repo ; subscription-manager repos will.

Version-Release number of selected component (if applicable):
subscription-manager-1.8.22-1.el6_4.x86_64

How reproducible:
all the time

Steps to Reproduce:
1. update subscription-manager and install subscription-manager-migrate onto a satellite-installed machine
2. register that machine against rhn classic
3. migrate the machine to rhsm using rhn-migrate-classic-to-rhsm --force
4. on the portal associate subscriptions to have access to the rhel6 server repos
5. use subscription-manager refresh

Actual results:
redhat.repo remains empty

Expected results:
redhat.repo is also updated as information are refreshed. instead, they only are refreshed if using subscrition-manager repos

Additional info:
internal ticket - no customer case attached at time of opening.
Comment 1 Carter Kozak 2013-10-29 13:18:52 EDT
I don't think this has anything to do with refresh.  If you run "yum repolist" to generate a yum transaction, the subscription-manager yum plugin will be invoked and generate a correct redhat.repo.

In newer versions of subscription-manager, if new certificates are pulled down, the redhat.repos file will be updated.

Please let me know if you have any questions.
Comment 2 Felix Dewaleyne 2013-10-29 13:34:41 EDT
no, one of the commands I did run 3 times between refreshes while trying to get the repos to work was

~~~
yum clean all
yum repolist
yum repolist all
~~~

that would ever only list the repos of the redhat-source.repo, redhat.repo wouldn't get updated.
Comment 4 Carter Kozak 2013-10-29 13:41:30 EDT
[root@vm-139 ~]# cat /etc/yum/pluginconf.d/subscription-manager.conf 
[main]
enabled=0

Setting enabled to 1 allows the subscription-manager plugin to update redhat.repos.  It is enabled by default.
Comment 6 Carter Kozak 2013-10-30 08:51:32 EDT
The last comment should resolve your problem, please let me know if there's something else going on.  When I logged into your machine and set enabled=1, everything worked as intended.

Please let me know if there's anything else you need.
Comment 7 Felix Dewaleyne 2013-10-30 10:29:12 EDT
yup that does solve the problem. too bad nothing pointed at a misconfiguration other than the behaviour, a warning / error message would have been nice.

Note You need to log in before you can comment on or make changes to this bug.