Bug 1024495 - Qupzilla always crashes on exit
Qupzilla always crashes on exit
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: qupzilla (Show other bugs)
20
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-29 15:13 EDT by Christian Stadelmann
Modified: 2013-10-31 14:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-29 18:19:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Stadelmann 2013-10-29 15:13:30 EDT
Description of problem:
Every time I exit Qupzilla it crashes

Version-Release number of selected component (if applicable): 1.4.4-1.fc20

How reproducible:
always. Even with clean settings and cache

Steps to Reproduce:
1. start qupzilla 
2. do or don't do surfing - does not matter
3. close qupzilla

Actual results:
crash

Expected results:
no crash

Additional info:
Reported this bug first here: https://github.com/QupZilla/qupzilla/issues/1071 but since it seems to be Fedora-specific I post it here.

I suspect this bug might be related to stack-smashing protection Fedora uses to build packages. A qupzilla developer at github asked me to provide the compiler flags used to build the binary. Can you please help him out?

Retrace server: https://retrace.fedoraproject.org/faf/reports/237372/
Comment 1 Rex Dieter 2013-10-29 15:31:06 EDT
I added requested information to the upstream report.
Comment 2 Rex Dieter 2013-10-29 15:32:06 EDT
And Fwiw, qupzilla runs fine for me (though admittedly don't use it much).

$ rpm -q qupzilla qtwebkit
qupzilla-1.4.4-1.fc20.x86_64
qtwebkit-2.3.3-1.fc20.x86_64
qtwebkit-2.3.3-1.fc20.i686
Comment 3 Christian Stadelmann 2013-10-29 18:19:47 EDT
Sorry for all that trouble. I found the reason: There was a manually built binary library from qupzilla I built some time ago and didn't correctly remove. I removed that library and reinstalled qupzilla (made sure no other qupzilla files are around) and qupzilla now works fine and doesn't crash at exit any more.
Comment 4 Christoph Wickert 2013-10-31 14:39:29 EDT
Thanks for the feedback. We are currently filtering out the libraries from the Provides/Requires of the package. So if you need one to install something on top of qupzilla (are there any extensions?), please let me know.

Note You need to log in before you can comment on or make changes to this bug.