Bug 102450 - watch -d reports spurious changes
watch -d reports spurious changes
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: procps (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-15 05:46 EDT by Kasper Dupont
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-11 08:35:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kasper Dupont 2003-08-15 05:46:06 EDT
Description of problem:
The watch command can show the output from a program periodically.
The -d option is intended to highlight changes. In some cases chars
are highlighted eventhough they have not changed.

Version-Release number of selected component (if applicable):
procps-2.0.11-6

How reproducible:
Happens every time.

Steps to Reproduce:
1. watch -d head /proc/sys/kernel/random/*
    
Actual results:
Parts of the first filename is highlighted.

Expected results:
Only the changing file contents should be highlighted.

Additional info:
The problem seems to be related to the length of the
command line.
Comment 1 Mike A. Harris 2003-08-18 03:42:13 EDT
Nice email address. ;o)
Comment 2 Alexander Larsson 2004-02-05 05:44:24 EST
Mass reassign to new owner
Comment 3 Daniel Walsh 2004-02-11 08:35:01 EST
Fixed in 3.1.15.

Note You need to log in before you can comment on or make changes to this bug.