This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1024512 - python-2.6 cartridge sometimes caches files
python-2.6 cartridge sometimes caches files
Status: CLOSED DEFERRED
Product: OpenShift Online
Classification: Red Hat
Component: Image (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Hadvig
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-29 16:05 EDT by Oleg Fayans
Modified: 2016-11-30 19:27 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 05:29:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oleg Fayans 2013-10-29 16:05:35 EDT
Description of problem:
Sometimes python-2.6 cartridge caches the python files. Even when I update the files and do git commit/push, then restart the app, the changes do not get applied, although files in the app on the appliance do get changed. 
I tried to remove all *.pyc files - no result. Only complete deletion of the app and creation it from scratch using the same code solves the problem

Version-Release number of selected component (if applicable):


How reproducible:
Observed it 2 times on Enterprise instance. Will search another platform for my project now. 

Steps to Reproduce:
1. create a python-2.6 app with postgresql-9.2 from code https://github.com/ofayans/servicestations.git
2. make some changes to a wsgi/preview/preview/widget.py or wsgi/preview/preview/admin.py so that the change would affect the django admin interface
3. git commit, git push

Actual results:
Most probably everythong will work but sometimes the changes would not be applied.


Expected results:


Additional info:
Comment 2 Brenton Leanhardt 2013-10-30 08:21:29 EDT
I'm assuming this is against 2.0.  If that is not the case please update the BZ accordingly.
Comment 3 Oleg Fayans 2013-10-31 10:59:08 EDT
UPD, removed github repo, since it violates customer's interests.
Comment 6 Jakub Hadvig 2014-01-21 05:29:59 EST
Not able to reproduce the issue.

After speaking to Oleg we decided to Close this issue, which could be ReOpened
if we encounter it.

Note You need to log in before you can comment on or make changes to this bug.