Bug 1024672 - cim %post scriptlet fails
cim %post scriptlet fails
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Ryan Barry
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 04:29 EDT by Fabian Deutsch
Modified: 2014-01-21 14:36 EST (History)
9 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-8.el6
Doc Type: Bug Fix
Doc Text:
The cim '%post scriptlet' was failing. This was caused by the snippet used in the '%post scriptlet' to pick the UID erroneously closed an expression by using a backtick instead of an apostrophe. This has been fixed so the '%post scriptlet' works correctly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:36:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabian Deutsch 2013-10-30 04:29:33 EDT
Description of problem:
The following output appears duringa livecd creation:

  Installing: ovirt-node-plugin-cim        ##################### [411/461]/var/tmp/rpm-tmp.LU7reU: line 7: unexpected EOF while looking for matching ``'
/var/tmp/rpm-tmp.LU7reU: line 24: conditional binary operator expected
/var/tmp/rpm-tmp.LU7reU: line 24: syntax error: unexpected end of file
warning: %post(ovirt-node-plugin-cim-3.0.1-999.0.20131023102234git0815b69.el6.noarch) scriptlet failed, exit status 2
Comment 6 Cheryn Tan 2014-01-08 00:36:08 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:
https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes

Thank you for your help.
Comment 7 haiyang,dong 2014-01-13 00:44:38 EST
Test version:
ovirt-node-plugin-cim-3.0.1-16.el6_5.noarch.rpm
ovirt-node-tools-3.0.1-16.el6_5.noarch

Test steps:
edit-node --repo=edit-node.repo --install=ovirt-node-plugin-cim-3.0.1-16.el6_5.noarch.rpm rhevh-6.5-20131220.0.iso

Test result:
[root@dhcp-11-127 home]# edit-node --repo=edit-node.repo --install=ovirt-node-plugin-cim-3.0.1-16.el6_5.noarch.rpm rhevh-6.5-20131220.0.iso
rhevh-6.5-20131220.0.iso
Setting SELinux Permissive During Yum Install
Installing Packages
Setting Up DNS For Chroot
Configuring Yum Repo
Running Yum Install
['ovirt-node-plugin-cim-3.0.1-16.el6_5.noarch.rpm']
Setting up Local Package Process
Examining /tmp/yumrepo/ovirt-node-plugin-cim-3.0.1-16.el6_5.noarch.rpm: ovirt-node-plugin-cim-3.0.1-16.el6_5.noarch
Marking /tmp/yumrepo/ovirt-node-plugin-cim-3.0.1-16.el6_5.noarch.rpm as an update to ovirt-node-plugin-cim-3.0.1-13.el6_5.noarch
Resolving Dependencies
--> Running transaction check
---> Package ovirt-node-plugin-cim.noarch 0:3.0.1-13.el6_5 will be updated
---> Package ovirt-node-plugin-cim.noarch 0:3.0.1-16.el6_5 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package
       Arch   Version        Repository                                    Size
================================================================================
Updating:
 ovirt-node-plugin-cim
       noarch 3.0.1-16.el6_5 /ovirt-node-plugin-cim-3.0.1-16.el6_5.noarch  23 k

Transaction Summary
================================================================================
Upgrade       1 Package(s)
....
  Updating   : ovirt-node-plugin-cim-3.0.1-16.el6_5.noarch                  1/2 
useradd: user 'cim' already exists
  Cleanup    : ovirt-node-plugin-cim-3.0.1-13.el6_5.noarch                  2/2 
  Verifying  : ovirt-node-plugin-cim-3.0.1-16.el6_5.noarch                  1/2 
  Verifying  : ovirt-node-plugin-cim-3.0.1-13.el6_5.noarch                  2/2 

Updated:
  ovirt-node-plugin-cim.noarch 0:3.0.1-16.el6_5                                 

Complete!
......
 97.58% done, estimate finish Mon Jan 13 05:19:00 2014
Total translation table size: 2048
Total rockridge attributes bytes: 6547
Total directory bytes: 14336
Path table size(bytes): 80
Max brk space used 1b000
122995 extents written (240 MB)
Inserting md5sum into iso image...
md5 = 2b30f0ccd0652ae166cd054bad938b40
Inserting fragment md5sums into iso image...
fragmd5 = 7d57c3b32856a5a143d5e939dbc386b84e2c8841111265cb66e799b5879a
frags = 20
Setting supported flag to 0
Moving 'rhevh-6.5-20131220.0.iso.edited.iso' to 'rhevh-6.5-20131220.cim.0.iso'

so install ovirt-node-plugin-cim-3.0.1-16.el6_5.noarch.rpm install rhevh iso suceess and also cim page functions work well by using new cim plugin.
this bug has been fixed, change the status into "verified"
Comment 8 Charlie 2014-01-14 19:23:31 EST
Hi could you let me know what the problem and fix was for the doctext? Thanks.
Comment 9 Ryan Barry 2014-01-14 19:51:12 EST
Moving ovirt-node-plugin-cim to a plugin rather than having those packages as part of the base image required moving user creation to the plugin RPM. The snippet used in the %post scriptlet to pick the UID erroneously closed an expression by using a backtick instead of an apostrophe.
Comment 11 errata-xmlrpc 2014-01-21 14:36:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.