Bug 1024720 - Can install openshift-origin-frontend-{apache-mod-rewrite,nodejs-websocket,apache-vhost} on the same node which should not be.
Can install openshift-origin-frontend-{apache-mod-rewrite,nodejs-websocket,ap...
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Rob Millner
libra bugs
: UpcomingRelease
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 06:16 EDT by Liang Xia
Modified: 2015-05-14 19:32 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-04 12:54:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Liang Xia 2013-10-30 06:16:26 EDT
Description of problem:
Can install openshift-origin-frontend-{apache-mod-rewrite,nodejs-websocket,apache-vhost} on the same node which should not be.

Version-Release number of selected component (if applicable):
devenv_3966

How reproducible:
always

Steps to Reproduce:
1.Install openshift-origin-frontend-apache-mod-rewrite on node.
2.Install openshift-origin-frontend-nodejs-websocket on the same node.
3.Install openshift-origin-frontend-apache-vhost on the same node.

Actual results:
The plugins installed successfully on the same node.
# rpm -qa | grep openshift-origin-frontend
rubygem-openshift-origin-frontend-apache-mod-rewrite-0.2.2-1.git.0.c26a387.el6.noarch
rubygem-openshift-origin-frontend-apachedb-0.2.1-1.git.0.1dad1bb.el6.noarch
rubygem-openshift-origin-frontend-apache-vhost-0.2.1-1.el6oso.noarch
rubygem-openshift-origin-frontend-nodejs-websocket-0.2.1-1.git.0.f3f0b7d.el6.noarch
rubygem-openshift-origin-frontend-haproxy-sni-proxy-0.1.7-1.git.0.012c092.el6.noarch

Expected results:
Should not be able to install openshift-origin-frontend-{apache-mod-rewrite,nodejs-websocket} and openshift-origin-frontend-apache-vhost on the same node.

Additional info:
Comment 1 Rob Millner 2013-11-04 12:54:09 EST
That decision was changed at the last minute due to OpenShift build and test issues.  The modules are now allowed to be installed and can even be configured together; however, we make no guarantees about the behaviour if both are configured.

Note You need to log in before you can comment on or make changes to this bug.