Bug 1024735 - Making MAIN_CLASS of opengrok replacable
Making MAIN_CLASS of opengrok replacable
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: opengrok (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 06:43 EDT by Masatake YAMATO
Modified: 2015-12-02 05:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-02 05:10:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch introduces OPENGROK_MAIN_CLASS environment variable (394 bytes, patch)
2013-10-30 06:43 EDT, Masatake YAMATO
no flags Details | Diff

  None (edit)
Description Masatake YAMATO 2013-10-30 06:43:52 EDT
Created attachment 817392 [details]
A patch introduces OPENGROK_MAIN_CLASS environment variable

Description of problem:

This is not a bug report. This is a request to merge a patch.


opengrok.jar provides a class named org.opensolaris.opengrok.search.Search for searching from commandline. However, opengrok command shipped as part
of fedora doesn't provide an interface for searching.
Because org.opensolaris.opengrok.index.Indexer class is hardcoded in the command,
the command can be used for indexing only through the command is useful for harness.


A patch attached to this post introduces OPENGROK_MAIN_CLASS environment variable. With the variable you can use opengrok command for searching like:


 $ export OPENGROK_MAIN_CLASS=org.opensolaris.opengrok.search.Search
 $ opengrok -R  CONFFILE -f PATTERN
Comment 1 Jaroslav Reznik 2015-03-03 10:10:07 EST
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22
Comment 2 Mat Booth 2015-12-02 05:10:10 EST
This package was retired:

http://pkgs.fedoraproject.org/cgit/opengrok.git/tree/dead.package

Note You need to log in before you can comment on or make changes to this bug.