Bug 1024804 - rhui-manager status diplays repo success when repo was removed and added again
rhui-manager status diplays repo success when repo was removed and added again
Status: CLOSED ERRATA
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: RHUA (Show other bugs)
2.1.2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 2.1.3
Assigned To: dgao
Ina Panova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 09:13 EDT by Ina Panova
Modified: 2013-12-17 15:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
This update fixes confusing entries in the synchronization history when a repository is deleted then re-added. The way the last synchronization is calculated now accounts for when a repository was deleted. The synchronization status now displays 'Never' when a repository has been re-added after deletion.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-17 15:10:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ina Panova 2013-10-30 09:13:59 EDT
Description of problem:

when a repo was added, synced, removed and re-added, rhui-manager status displays wrong repo status 'Success' instead of 'Never'.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Add rh repo
2. Sync rh repo
3. Remove rh repo
4. Add same rh repo
5. check 'rhui-manager status'

[root@rhua ~]# rhui-manager status

Red Hat Enterprise Linux 5 Server Beta from RHUI (Debug RPMs) (5Server-x86_64)  [  SUCCESS  ]

Identity certificate expiration date = 2033-10-24T17:02:14Z  .......... [  OK  ]

Entitlement CA certificate expiration date = 2014-10-29T10:09:54Z  .... [  OK  ]
0

Actual results:
rh repo status is SUCCESS

Expected results:
rh repo status is NEVER
Comment 1 dgao 2013-10-31 12:17:19 EDT
rhui-manager status
ec2-54-235-34-57.compute-1.amazonaws.com .................... [  UP  ]

ec2-54-235-34-57.compute-1.amazonaws.com .................... [  NEVER  ]
ec2-54-221-3-51.compute-1.amazonaws.com ..................... [  UP  ]

ec2-54-221-3-51.compute-1.amazonaws.com ..................... [  NEVER  ]

Red Hat Enterprise Linux 6 Server - Supplementary from RHUI (Debug RPMs) (6Server-i386)  [  NEVER  ]

Identity certificate expiration date = 2023-10-28T22:01:00Z  .......... [  OK  ]

Entitlement CA certificate expiration date = 2033-10-25T22:00:13Z  .... [  OK  ]
0


cloude commit: c2b3cdb2a37e957df7f065a9cea018bdd423126b
Comment 2 Ina Panova 2013-11-06 05:02:10 EST
tested in 
pulp-0.0.263-40.el6_5.noarch
rh-rhui-tools-2.1.28-1.el6_5.noarch
rh-rhui-tools-debug-script-2.1.28-1.el6_5.noarch

Move to Verified.
Comment 4 errata-xmlrpc 2013-12-17 15:10:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1854.html

Note You need to log in before you can comment on or make changes to this bug.