Bug 1024812 - rhui-manager status diplays cds success when cds was removed and added again
rhui-manager status diplays cds success when cds was removed and added again
Status: CLOSED ERRATA
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: RHUA (Show other bugs)
2.1.2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 2.1.3
Assigned To: dgao
Ina Panova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 09:23 EDT by Ina Panova
Modified: 2013-12-17 15:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
This update fixes the synchronization status of a Content Delivery Server that has been deleted and re-added. When a Content Delivery Server was deleted and re-added the synchronization status displayed the details of the last synchronization prior to deletion. Logic has been added to determine if this is the first synchronization after the Content Delivery Server since deletion. The synchronization status now displays 'Never' if the Content Delivery Server has not been synchronized since it was re-added.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-17 15:10:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1854 normal SHIPPED_LIVE Red Hat Update Infrastructure 2.1.3 bug fix update 2013-12-17 20:07:53 EST

  None (edit)
Description Ina Panova 2013-10-30 09:23:37 EDT
Description of problem:

when cds is registered, synced, removed and re-added, rhui-manager status displays wrong cds status 'Success' instead of 'Never'.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Register cds
2. Sync cds
3. Remove cds
4. Add cds
5. Check 'rhui-manager status'

[root@rhua ~]# rhui-manager status
cds1.example.com ............................................ [  UP  ]

cds1.example.com ............................................ [  SUCCESS  ]

Identity certificate expiration date = 2033-10-24T17:02:14Z  .......... [  OK  ]

Entitlement CA certificate expiration date = 2014-10-29T10:09:54Z  .... [  OK  ]
0

Actual results:
cds status is SUCCESS

Expected results:
cds status is NEVER
Comment 1 dgao 2013-10-31 12:14:37 EDT
rhui-manager status
ec2-54-235-34-57.compute-1.amazonaws.com .................... [  UP  ]

ec2-54-235-34-57.compute-1.amazonaws.com .................... [  NEVER  ]
ec2-54-221-3-51.compute-1.amazonaws.com ..................... [  UP  ]

ec2-54-221-3-51.compute-1.amazonaws.com ..................... [  NEVER  ]

Red Hat Enterprise Linux 6 Server - Supplementary from RHUI (Debug RPMs) (6Server-i386)  [  NEVER  ]

Identity certificate expiration date = 2023-10-28T22:01:00Z  .......... [  OK  ]

Entitlement CA certificate expiration date = 2033-10-25T22:00:13Z  .... [  OK  ]
0


cloude commit: c2b3cdb2a37e957df7f065a9cea018bdd423126b
Comment 2 Ina Panova 2013-11-06 04:46:55 EST
tested in 
pulp-0.0.263-40.el6_5.noarch
rh-rhui-tools-2.1.28-1.el6_5.noarch
rh-rhui-tools-debug-script-2.1.28-1.el6_5.noarch

Move to Verified.
Comment 4 errata-xmlrpc 2013-12-17 15:10:53 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1854.html

Note You need to log in before you can comment on or make changes to this bug.