Bug 102513 - kppp locks X in KDE desktop
kppp locks X in KDE desktop
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdenetwork (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-16 04:08 EDT by warren thomason
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-03 15:32:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description warren thomason 2003-08-16 04:08:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux)

Description of problem:
clicking on kppp connects to my ISP, but X seems to lock.
ctl-alt-bs will not kill X
forces a manual reboot
Note: KPPP works fine if I use main menu-Internet-More Internet Applications-KPPP
Only have the problem if I use KDE desktop with kppp added to the panel
as a normal user.  Works fine as root with KDE desktop.  Works fine with the Gnome desktop as either root or a normal user. Only the KDE desktop as a normal user and Kppp icon on the panel locks X. 
 
	


Version-Release number of selected component (if applicable):
kdenetwork-3.1-5

How reproducible:
Always

Steps to Reproduce:
1.Kde desktop as normal user
2.Rght click on panel - ADD - main menu - internet - more internet application-kppp
3.Left click on kppp icon      

Actual Results:  Kppp connects to ISP just fine.
X locks(hangs?)
CTL-ALT-BS will not kill X
Forces a manual(button) reset

Expected Results:  other icons should respond.

Additional info:

Had exactly the same problem with 2 other machines and Redhat 8.0.
Everything worked fine with 7.2.
Comment 1 warren thomason 2003-08-18 00:20:38 EDT
My first bug report is in error.  I don't think it is locking X, 
just locking the panel.  Have found a workaround. 
1. Added application kde admin tools  from  the CD(may or may have had an affect) 
2. Deleted the kppp icon from the panel and kppp from the task bar. 
      Stupid user error! 
      Lost all info so logged out and got the info from the the icon I had 
      previouly added to the gnome panel. 
3. Logged back into kde.  Rebuilt the entry on the task bar, threw a right click on the main  
     menu buttom with the info from the gnome panel icon.  Execute command is kppp %l %m. 
    Checked to make sure it worked 
    and then added it to the KDE by right clicking on panel and adding an application button. 
Works! 
    Was a bit worried about permisssions, but the funny thing is they seem even more restrictive 
    now.  The panel icon properties says  owner read write and I am the listed owner. 
    Before the deletions, owner had read write, and group and other had read access. 
Have used it today with no further problems.        
Comment 2 Ngo Than 2003-09-03 15:32:51 EDT
it's fixed in 3.1.3-4 or newer. it should work fine if you remove the line
X-DCOP-ServiceType=Multi in /usr/share/applications/kde-Kppp.desktop

Note You need to log in before you can comment on or make changes to this bug.