Bug 1025252 - [RFE] Unified prefix for kernel arguments
[RFE] Unified prefix for kernel arguments
Status: CLOSED WONTFIX
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
4.0
Unspecified Unspecified
high Severity high
: ---
: 3.6.0
Assigned To: Fabian Deutsch
bugs@ovirt.org
node
: FutureFeature
: 1028929 (view as bug list)
Depends On:
Blocks: 1028929
  Show dependency treegraph
 
Reported: 2013-10-31 06:22 EDT by Fabian Deutsch
Modified: 2016-02-10 14:39 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1028929 (view as bug list)
Environment:
Last Closed: 2015-06-05 07:01:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabian Deutsch 2013-10-31 06:22:08 EDT
Description of problem:
Currently most kernel arguments used by Node are not having a prefix. To prevent collisions (e.g. bug 1020700) with other parts of the system Node's kernel arguments should be prefixed with a common prefix.

Some prefix ideas:
node.
nd.

node.example=foo
nd.example=foo
Comment 1 Sandro Bonazzola 2014-03-04 04:27:06 EST
This is an automated message.
Re-targeting all non-blocker bugs still open on 3.4.0 to 3.4.1.
Comment 2 Sandro Bonazzola 2014-06-11 03:04:45 EDT
This is an automated message:
oVirt 3.4.2 has been released.
This bug has been re-targeted from 3.4.2 to 3.4.3 since priority or severity were high or urgent.
Comment 3 Sandro Bonazzola 2014-06-11 03:05:22 EDT
This is an automated message:
oVirt 3.4.2 has been released.
This bug has been re-targeted from 3.4.2 to 3.4.3 since priority or severity were high or urgent.
Comment 4 Itamar Heim 2014-06-29 05:07:10 EDT
*** Bug 1028929 has been marked as a duplicate of this bug. ***
Comment 5 Fabian Deutsch 2015-04-23 09:54:58 EDT
This change would be really disruptive for the existing node. And the next gen node will not reuse the current auto-installation logic.

Note You need to log in before you can comment on or make changes to this bug.