Bug 1025259 - Second host installation fails because of wrong ENV OVEHOSTED_VDSM in answers file.
Second host installation fails because of wrong ENV OVEHOSTED_VDSM in answers...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup (Show other bugs)
unspecified
Unspecified Unspecified
urgent Severity urgent
: ---
: 3.3.0
Assigned To: Sandro Bonazzola
Leonid Natapov
integration
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-31 06:40 EDT by Leonid Natapov
Modified: 2014-01-21 11:54 EST (History)
6 users (show)

See Also:
Fixed In Version: ovirt-hosted-engine-setup-1.0.0-0.8.beta3.el6ev
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:54:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20777 None None None Never
oVirt gerrit 20858 None None None Never

  None (edit)
Description Leonid Natapov 2013-10-31 06:40:43 EDT
It seems that the subject of certificate is changed using the output of a query to the certificate on first host. It's created with: OVEHOSTED_VDSM/spicePkiSubject=str:'/C=EN/L=Test/O=Test/CN=Test' 

and then updated to 
ENV OVEHOSTED_VDSM/spicePkiSubject=unicode:'O=Test, CN=10.35.102.11'

User gets the following error:
[ ERROR ] Failed to execute stage 'Misc configuration': Command '/usr/bin/openssl' failed to execute

Here is the setup log file output.
---------------------------

2013-10-31 11:47:28 DEBUG otopi.plugins.ovirt_hosted_engine_setup.pki.vdsmpki plugin.execute:446 execute-output: ('/usr/bin/openssl', 'req', '-new', '-x509', '-days', '1095', '-key', '/tmp/tmpgkQD_
9/ca-key.pem', '-out', '/tmp/tmpgkQD_9/ca-cert.pem', '-subj', 'O=Test, CN=10.35.102.11') stderr:
Subject does not start with '/'.
problems making Certificate Request

2013-10-31 11:47:28 DEBUG otopi.context context._executeMethod:137 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/otopi/context.py", line 127, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/ovirt-hosted-engine-setup/pki/vdsmpki.py", line 206, in _misc
    self._generateSPICEcerts()
  File "/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/ovirt-hosted-engine-setup/pki/vdsmpki.py", line 122, in _generateSPICEcerts
    raiseOnError=True
  File "/usr/lib/python2.6/site-packages/otopi/plugin.py", line 451, in execute
    command=args[0],
RuntimeError: Command '/usr/bin/openssl' failed to execute
2013-10-31 11:47:28 ERROR otopi.context context._executeMethod:146 Failed to execute stage 'Misc configuration': Command '/usr/bin/openssl' failed to execute
Comment 1 Sandro Bonazzola 2013-10-31 07:30:56 EDT
this bug can be seen only on second host when using SPICE as console, it doesn't affect setup using VNC.
Comment 2 Sandro Bonazzola 2013-11-04 09:01:41 EST
patch merged on upstream master and 1.0 branch
Comment 4 Leonid Natapov 2013-11-12 07:54:19 EST
fixed
Comment 5 Charlie 2013-11-27 20:19:34 EST
This bug is currently attached to errata RHBA-2013:15257. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 6 Sandro Bonazzola 2013-12-05 05:45:20 EST
hosted engine is a new package, does not need errata for specific bugs during its development.
Comment 7 errata-xmlrpc 2014-01-21 11:54:53 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0083.html

Note You need to log in before you can comment on or make changes to this bug.